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Warranty

The media on which you receive National Instruments software are warranted not to fail to execute programming
instructions, due to defects in materials and workmanship, for a period of 90 days from date of shipment, as evid
by receipts or other documentation. National Instruments will, at its option, repair or replace software media that 
execute programming instructions if National Instruments receives notice of such defects during the warranty pe
National Instruments does not warrant that the operation of the software shall be uninterrupted or error free.

A Return Material Authorization (RMA) number must be obtained from the factory and clearly marked on the outs
of the package before any equipment will be accepted for warranty work. National Instruments will pay the shipping
of returning to the owner parts which are covered by warranty.

National Instruments believes that the information in this manual is accurate. The document has been carefully re
for technical accuracy. In the event that technical or typographical errors exist, National Instruments reserves the 
make changes to subsequent editions of this document without prior notice to holders of this edition. The reader 
consult National Instruments if errors are suspected. In no event shall National Instruments be liable for any dam
arising out of or related to this document or the information contained in it.

EXCEPT AS SPECIFIED HEREIN, NATIONAL  INSTRUMENTS MAKES NO WARRANTIES, EXPRESS OR IMPLIED, AND 
SPECIFICALLY DISCLAIMS ANY WARRANTY OF MERCHANTABILITY  OR FITNESS FOR A PARTICULAR PURPOSE. CUSTOMER’S 
RIGHT TO RECOVER DAMAGES CAUSED BY FAULT OR NEGLIGENCE ON THE PART OF NATIONAL  INSTRUMENTS SHALL BE 
LIMITED  TO THE AMOUNT THERETOFORE PAID BY THE CUSTOMER. NATIONAL  INSTRUMENTS WILL  NOT BE LIABLE  FOR 
DAMAGES RESULTING FROM LOSS OF DATA, PROFITS, USE OF PRODUCTS, OR INCIDENTAL OR CONSEQUENTIAL DAMAGES, 
EVEN IF ADVISED OF THE POSSIBILITY THEREOF. This limitation of the liability of National Instruments will apply 
regardless of the form of action, whether in contract or tort, including negligence. Any action against National 
Instruments must be brought within one year after the cause of action accrues. National Instruments shall not be li
any delay in performance due to causes beyond its reasonable control. The warranty provided herein does not c
damages, defects, malfunctions, or service failures caused by owner’s failure to follow the National Instruments 
installation, operation, or maintenance instructions; owner’s modification of the product; owner’s abuse, misuse, 
negligent acts; and power failure or surges, fire, flood, accident, actions of third parties, or other events outside rea
control.

Copyright

Under the copyright laws, this publication may not be reproduced or transmitted in any form, electronic or mecha
including photocopying, recording, storing in an information retrieval system, or translating, in whole or in part, wit
the prior written consent of National Instruments Corporation.

Trademarks

BridgeVIEW™, LabVIEW™, National Instruments™, natinst.com™, NI-DAQ™, and SCXI™ are trademarks of 
National Instruments Corporation.

Product and company names listed are trademarks or trade names of their respective companies.

WARNING REGARDING MEDICAL AND CLINICAL USE OF NATIONAL INSTRUMENTS PRODUCTS

National Instruments products are not designed with components and testing intended to ensure a level of reliab
suitable for use in treatment and diagnosis of humans. Applications of National Instruments products involving m
or clinical treatment can create a potential for accidental injury caused by product failure, or by errors on the part
user or application designer. Any use or application of National Instruments products for or involving medical or cl
treatment must be performed by properly trained and qualified medical personnel, and all traditional medical safeg
equipment, and procedures that are appropriate in the particular situation to prevent serious injury or death should
continue to be used when National Instruments products are being used. National Instruments products are NOT i
to be a substitute for any form of established process, procedure, or equipment used to monitor or safeguard huma
and safety in medical or clinical treatment.
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The BridgeVIEW Run-Time System Guide contains the information you 
need to get started with the BridgeVIEW Run-Time System software 
package. This manual explains the BridgeVIEW environment, tag 
configuration, alarms and events, and historical data logging and 
extraction.

This manual assumes that you know how to operate your computer and
you are familiar with its operating system.

Organization of This Manual

• Chapter 1, Introduction, describes the unique BridgeVIEW approac
to Supervisory Control and Data Acquisition (SCADA). It also 
contains system configuration, installation instructions and basic 
information that explains how to use BridgeVIEW.

• Chapter 2, BridgeVIEW Environment, describes the BridgeVIEW 
environment. It explains the BridgeVIEW Engine Manager, system
errors and events, the Tag Monitor utility, and the Tag Browser utili
This chapter also explains how to access online help for BridgeVIE

• Chapter 3, Tag Configuration, explains tags, the Tag Configuration 
Editor, and how you edit tags within the BridgeVIEW system.

• Chapter 4, Alarms and Events, introduces the basic concepts of alarm
and events, and explains how to view, acknowledge, and configure
them within the BridgeVIEW system.

• Chapter 5, Historical Data Logging and Extraction, explains the 
concept of a trend, how to log and extract historical data, and how
use the Historical Trend Viewer (HTV), a utility that displays historic
data that has been logged to disk with BridgeVIEW.

• Chapter 6, BridgeVIEW Security, explains BridgeVIEW Environment 
Security.

• Chapter 7, Servers, explains how to use servers with BridgeVIEW. 
BridgeVIEW supports several types of servers including OPC Serv
DDE Servers, and IA Device Servers.

• Appendix A, Citadel and Open Database Connectivity, describes the 
Citadel database and the Open Database Connectivity (ODBC) dri
and includes several examples of how to use it. 
© National Instruments Corporation xiii BridgeVIEW Run-Time System Guide



About This Manual

, 

e, 

er 
tax 
 

 

puter 
ode 

s or 

ple, 

 

• Appendix B, Customer Communication, contains forms to help 
you gather the information necessary to help us solve your 
technical problems, and a form you can use to comment on 
the product documentation.

• The Glossary contains an alphabetical list of terms used in this 
manual, including abbreviations, acronyms, metric prefixes, 
mnemonics, and symbols.

• The Index contains an alphabetical list of key terms and topics in 
this manual, including the page where you can find each one.

Conventions Used in This Manual

The following conventions are used in this manual:

bold Bold text denotes a parameter, menu name, palette name, menu item
return value, function panel item, or dialog box button or option.

italic Italic text denotes mathematical variables, emphasis, a cross referenc
or an introduction to a key concept.

bold italic Bold italic text denotes an activity objective, note, caution, or warning.

monospace Text in this font denotes text or characters that you should literally ent
from the keyboard. Sections of code, programming examples, and syn
examples also appear in this font. This font also is used for the proper
names of disk drives, paths, directories, programs, subprograms, 
subroutines, device names, variables, filenames, and extensions, and
for statements and comments taken from program code.

monospace bold Bold text in this font denotes the messages and responses that the com
automatically prints to the screen. This font also emphasizes lines of c
that are different from the other examples.

monospace italic Italic text in this font denotes that you must enter the appropriate word
values in the place of these items.

<> Angle brackets enclose the name of a key on the keyboard—for exam
<PageDown>.

- A hyphen between two or more key names enclosed in angle brackets
denotes that you should simultaneously press the named keys—for 
example, <Control-Alt-Delete>.

<Control> Key names are capitalized.
BridgeVIEW Run-Time System Guide xiv © National Instruments Corporation
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» The » symbol leads you through nested menu items and dialog box opt
to a final action. The sequence File»Page Setup»Options»Substitute 
Fonts directs you to pull down the File menu, select the Page Setup item, 
select Options, and finally select the Substitute Fonts option from the last 
dialog box.

paths Paths in this manual are denoted with backslashes (\) to separate dri
names, directories, and files, as in C:\dir1name\dir2name\filename .

This icon to the left of bold italicized text denotes a note, which alerts y
to important information.

Related Documentation

The following document contains information that you might find helpf
as you read this manual:

• BridgeVIEW Run-Time System Online Reference, available online by 
selecting Help»Online Reference

Customer Communication

National Instruments wants to receive your comments on our products
and manuals. We are interested in the applications you develop with o
products, and we want to help if you have problems with them. To mak
easy for you to contact us, this manual contains comment and configura
forms for you to complete. These forms are in Appendix B, Customer 
Communication, at the end of this manual.
© National Instruments Corporation xv BridgeVIEW Run-Time System Guide
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Introduction

This chapter describes the unique BridgeVIEW approach to 
Human Machine Interface (HMI) and Supervisory Control and Data 
Acquisition (SCADA). It also contains system configuration, installation
instructions, and basic information that explains how to use BridgeVIE
This chapter refers you to other chapters or manuals for more informa

Welcome to BridgeVIEW

The BridgeVIEW Run-Time System provides an environment to run 
Human Machine Interface (HMI) and SCADA applications developed 
the BridgeVIEW Full Development System.

Required System Configuration
The BridgeVIEW Run-Time System is distributed on a CD-ROM that 
includes the complete BridgeVIEW Run-Time System2.0 release.

The Windows 95/NT version of the BridgeVIEW Run-Time System 
runs on any system that supports Windows 95 or Windows NT 4.0. 
A minimum of 24 MB of RAM is required for this version to run 
effectively. We recommend 32 MB of RAM and at least 30 MB of 
swap space available on your system.

Note The standard BridgeVIEW Run-Time System installation requires approximate
40 to 60 MB of disk space.  If you plan to install the NI-DAQ Server as well, an
additional 30 MB of disk space is required.

Installation
Complete the following steps to install the BridgeVIEW Run-Time 
System.

1. Insert the CD in your CD-ROM drive. 

2. Run the BridgeVIEW Run-Time System installer. 

a. If you have Windows 95 or Windows NT 4.0 and your system 
uses the AutoPlay feature, the Welcome to BridgeVIEW scree
appears a short time after you insert the CD.
me System Guide
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b. If you have a system not using AutoPlay, run the following 
program:
X:\bvsetup.exe  
where X is the letter of your CD-ROM drive.

3. Choose an installation. The installer offers several installation type
Standard, Full, Minimum, and Custom. The Standard installation 
requires approximately 40 to 60 MB.

Note Consult your application software documentation or check with your system 
developer to determine which type of installation to choose. See the Where Should 
I Start? section later in this chapter for more information on the different 
installation types. 

4. After selecting an installation, follow the instructions that appear o
your screen.

What Is BridgeVIEW?

BridgeVIEW is a software package specifically targeted at industrial 
automation applications. BridgeVIEW provides configurable solutions f
common HMI and SCADA functions while leveraging the flexibility of 
graphical programming. BridgeVIEW is built around the G programmin
language, created by National Instruments Corporation.

With BridgeVIEW, you can acquire data and control one or more 
distributed devices in an overall facility. BridgeVIEW can change set poi
or send control instructions to the individual devices while monitoring t
entire system. It also can gather information like alarms and measurem
points from these devices.

Common devices used for data acquisition include Programmable Log
Controllers (PLCs), plug-in Data Acquisition boards, and other distribu
Input/Output (I/O) modules. BridgeVIEW device servers communicate
with these non-plug-in devices through RS-232, RS-485, TCP/IP, DDE
netDDE, direct I/O, or other proprietary interfaces. BridgeVIEW device
servers provide the necessary protocol software to communicate with 
these devices. BridgeVIEW also operates directly with OPC servers.

The BridgeVIEW Run-Time System is an execution environment for 
applications (also referred to here as application software) created usi
the BridgeVIEW Development System. With the Run-Time System, yo
cannot edit the Virtual Instruments (VIs) used to create the HMI of an 
application. Your application software consists of a set of VIs for the H
and supporting functionality of the software, the definition of all data poin
BridgeVIEW Run-Time System Guide 1-2 © National Instruments Corporation
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in the system (tags), and the configuration of the servers that provide 
to BridgeVIEW and your application.

This guide does not address the specific nature of the application 
software executed in the BridgeVIEW Run-Time System. Instead, it 
describes the features of BridgeVIEW, its architecture, execution syste
and configuration tools. The creator of your application software (refer
to here as the developer) might provide additional documentation for t
application software. Consult the application developer for specific 
questions about your application software.

How Does BridgeVIEW Work?

BridgeVIEW uses a combination of tags, events, and data. A tag is a 
connection to a real-world I/O point, while an event is anything that 
happens to a tag or to the BridgeVIEW Engine in general. The 
BridgeVIEW Engine communicates with device servers on one end, 
and with your HMI application at the other end. The BridgeVIEW 
Engine maintains a Real-Time Database (RTDB) of tag information an
logs historical data and events.

Start by configuring all the tags in your system with the Tag Configurati
Editor. Then, you can launch the BridgeVIEW Engine, which reads yo
configuration file and starts monitoring tags, logging data and events. Y
also can acknowledge alarms and control output tags. For more informa
about how to get started with the BridgeVIEW Run-Time System, see 
Where Should I Start? section later in this chapter.

Tag Configuration
A tag value is acquired and/or controlled by a device server that 
communicates with the BridgeVIEW Engine. Tags can be of the followi
types: input, output, Input/Output, or memory. You can configure tags
through the Tag Configuration Editor. A tag configuration consists of it
data type, connection, scaling, operations, and alarms settings. For m
information about this topic, refer to Chapter 3, Tag Configuration. 

Data Type
A tag data type can be analog, discrete, bit array, or string. Analog tags
have continuous values with a specified range (such as 0.0 to 100.0).
Discrete tags have values that are either ON (1) or OFF (0). Bit array 
are comprised of up to 32 bits, each of which can have an ON (1) or OFF
© National Instruments Corporation 1-3 BridgeVIEW Run-Time System Guide
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state. String tags consist of ASCII characters or binary data and can b
any length.

General
General includes the following tag attributes:

• Tag name

• Tag description

• Tag group

• Length (for bit array and string tags)

Connection
Connection includes the following tag attributes: 

• Access rights (input only, output only, Input/Output, or memory)

• Server name

• I/O group name

• Item name

• Access path (for OPC servers)

Scaling
Scaling controls the type of scaling to perform on a tag when 
communicating with a device server, and the expected engineering 
range and units for the tag.

Operations
You can specify how the BridgeVIEW Engine updates the Real-Time 
Database (RTDB), when it logs the tag data to disk, if it logs events 
associated with the tag, and what value exists in the database at start
Theoperations that can be performed on a tag are as follows:

• Updating the Real-Time Database 

• Historical logging 

• Event logging 

• Event printing

Alarms
An alarm is an abnormal process condition. For example, an analog 
tag can be configured to be in a HI alarm state when its value is great
BridgeVIEW Run-Time System Guide 1-4 © National Instruments Corporation
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than 25. You can set alarm limits for a tag in the Tag Configuration Edit
Each alarm limit has a priority associated with it to determine the seve
of the alarm.

Events
An event is something that happens within the BridgeVIEW system. 
Events can be divided into two groups: those that pertain to individual
tags and those that pertain to the overall BridgeVIEW system. Events 
pertaining to tags include the following:

• A tag going in or out of alarm

• An operator changing the value of a tag

• An operator acknowledging an alarm

Events pertaining to the system include the following: 

• The launching or shutting down of the Engine

• A new operator logging on

• An error from a server

The Engine also maintains alarm summary and event history informat
pertaining to tags. This information can be viewed by your HMI and/or 
logged to disk.

Historical Data Logging and Extraction
You can extract data from the historical database to view the trend of 
data over time. The BridgeVIEW Engine manages logging data to the
Citadel Historical Database. A trend is a view of data over time. Trends can
be real-time (current data) or historical (logged data). You can view log
data with a user interface (HMI) or with the Historical Trend Viewer 
(HTV). For more information about historical data logging and extracti
or the Citadel Historical Database, see Chapter 5, Historical Data Logging 
and Extraction, or Appendix A, Citadel and Open Database Connectivity. 

Security
Environment security is built into BridgeVIEW and determines access
certain parts of the BridgeVIEW environment. BridgeVIEW security is 
broken into two general categories: 

• BridgeVIEW Environment Access Privileges

• Operator Interface Security
© National Instruments Corporation 1-5 BridgeVIEW Run-Time System Guide
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What Is the BridgeVIEW System Architecture?

The BridgeVIEW system contains three sets of processes: the user H
Application, the BridgeVIEW Engine, and industrial automation device
servers, as shown in Figure 1-1. These processes interact through a 
client-server relationship.

 

Figure 1-1.  BridgeVIEW Architecture

The BridgeVIEW Engine, with any device servers, runs as a separate 
process independent of your HMI application. Your HMI application is
built as a collection of VIs developed using the G programming langua

BridgeVIEW maintains a high performance Real-Time Database in 
the BridgeVIEW Engine that provides information to client applications
The BridgeVIEW Engine also performs other functions including 
the following:

• Data acquisition, engineering unit (EU) scaling, and alarm process

• Alarm and event logging

• Historical data collection and trending

EU scaling converts the Raw Range value from the device server to th
engineering value used in the user application and vice versa. 

BridgeVIEW Engine
The BridgeVIEW Engine is the heart of the BridgeVIEW System. 
This minimizes interference between the Engine and your HMI. The 
BridgeVIEW Engine maintains the Real-Time Database of all tag valu
and alarm states. It reads values from the various device servers. The

Tags

• EU Scaling

• Alarming

• Event/Alarm Logging

• Trending

PLC DAQ OPC Other (including DDE)

HMIs

Real-Time Database

Servers

VIs

BridgeVIEW
Engine
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values are scaled and compared with their alarm limits. If a tag is in an
alarm state, the Engine generates appropriate events and logs them to

The Real-Time Database (RTDB) is an in-memory snapshot of the stat
all tags in the system. If a tag value changes more than its update dead
or its alarm state changes, the RTDB is updated. Along with tag values
RTDB also stores status, date, time, and alarm information. 

Device Servers
A device server is the application that communicates with the I/O devic
such as PLCs and plug-in cards. Several National Instruments device
servers are written to a National Instruments standard client/server 
Application Programming Interface (API) for the BridgeVIEW 
Engine. BridgeVIEW also communicates with OPC and DDE Servers.
There are different servers for different device manufacturers and 
communication networks.

The device servers that support the BridgeVIEW Engine are stand-alo
programs launched by the BridgeVIEW Engine, and thereafter run in t
background, reading selected input items and writing them on demand
Each server either is configured by BridgeVIEW when tags are create
or has a specific configuration utility that determines communication 
parameters, I/O poll rates, and device addresses. A server completes
operation only when the BridgeVIEW Engine shuts down.

Input items are polled by servers at a rate determined by the BridgeVI
I/O group configuration. For each input item, the device server passes
the value, the timestamp of when the item was sampled, and status 
information to the BridgeVIEW Engine. Output items are written on 
demand only when the BridgeVIEW Engine passes a new output 
value to the server.

The device server monitors the items and encapsulates all device and
hardware-specific details, thereby providing a hardware- and 
software-independent layer to the user HMI and SCADA application. 
For more information about device servers, see Chapter 7, Servers.
© National Instruments Corporation 1-7 BridgeVIEW Run-Time System Guide
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Where Should I Start?

Install the BridgeVIEW Run-Time System 
See the Installation section at the beginning of this chapter for more 
information on installation. The following table lists what is included in th
different installation types.

Note The Launch Engine, Login, Logout, Change Password, and Edit User Account
utilities are always installed.

In addition, you might need to install additional drivers for use with you
application software during the BridgeVIEW Run-Time System setup. 
You might also need to install additional data servers for your applicat
software. Consult the documentation for your application software.

Install the Application Software
Follow the instructions provided by the system developer for installing 
application software. After installing the files, note the location of the .scf 

and .ccdb  files.

Installation 
Type Includes

Minimum Tag Configuration Editor, basic security tools, 
core VI libraries

Standard Tag Configuration Editor, all security tools, 
Historical Trend Viewer, Tag Browser, Tag 
Monitor, core VI libraries, advanced analysis 
libraries, and online help,

Full Tag Configuration Editor, all security tools, 
Historical Trend Viewer, Tag Browser, 
Tag Monitor, core VI libraries, advanced 
analysis libraries, online help,Instrument Wizard, 
DAQ, GPIB, and VISA libraries

Custom Select which utilities and libraries to install.
BridgeVIEW Run-Time System Guide 1-8 © National Instruments Corporation
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Install the Required Servers
If your application software uses the NI-DAQ Server for BridgeVIEW, 
install the NI-DAQ Server from the BridgeVIEW Run-Time System CD
Other servers must be installed separately.

Update Preference Files
Consult the documentation for your application software to ensure any
specific preference files for the application are placed in the correct 
locations. These files contain non-default settings for BridgeVIEW utiliti
such as htv.ini . You can edit these files with a simple text editor such 
Notepad. Specific instructions about these preference files should be 
included with your application software.

Finish Server Setup
For National Instruments Device Servers, you might need to resolve th
paths to the servers stored in the .ccdb  file. Use the Server Explorer to do
this. The Server Explorer is installed when you install servers from the
National Instruments Device Servers CD. Start the Server Explorer, se
File»Open…, locate the .ccdb  file for your application software, and 
choose File»Set this file as Active CCDB.

VI-based servers (if used by your application) provide their own Serve
Registration VIs, as described in your application software documenta

Configure BridgeVIEW Startup 
Launch the BridgeVIEW Run-Time System. The first time you run it, 
you might be prompted to configure one or more startup VIs, as show
the illustration below. These startup VIs are the user interface panels 
appear when you launch the BridgeVIEW Run-Time System. Use the 
Configure BridgeVIEW Startup dialog box to locate the appropriate star
VIs, as identified in your application software documentation. If you do n
define at least one startup VI, you are prompted to either configure the
startup VIs or exit the application. 
© National Instruments Corporation 1-9 BridgeVIEW Run-Time System Guide
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If your application starts the engine when it launches, and the servers
not registered properly, you receive error messages identifying the ser
that did not start. Consult your application software documentation for
more information about which servers are required, and how to registe
them. 
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BridgeVIEW Environment

This chapter describes the BridgeVIEW environment. It explains the  
BridgeVIEW Engine Manager, system errors and events, the Tag Mon
utility, and the Tag Browser utility. This chapter also explains how to 
access online help for BridgeVIEW.

BridgeVIEW Environment Project Menu

Note Your application software might not provide access to the Project menu. 
If you require access to this menu, contact the application developer.

The BridgeVIEW system is comprised ofa collection of software tools 
designed specifically for industrial automation applications. You can 
access these tools through the Project menu in your BridgeVIEW system. 
Table 2-1 provides a brief description of the items in the Project menu.

Table 2-1.  BridgeVIEW Project Menu Items

Project Menu Item Description

Configure BridgeVIEW 
Startup

Opens a utility you can use to configure BridgeVIEW to start 
particular VIs whenever you start BridgeVIEW.

Historical Trend Viewer Launches the Historical Trend Viewer (HTV). You can use the 
HTV to view historical data logged in the Citadel Historical 
Database. For more information about the HTV, see Chapter 5,
Historical Data Logging and Extraction. 

Launch Engine Launches the BridgeVIEW Engine. The BridgeVIEW Engine 
manages the Real-Time Database, communicates with device 
servers, and performs alarm management and historical data 
logging. The BridgeVIEW Engine runs according to a 
configuration file called a .scf  (SCADA Configuration File) 
file. You can create and edit .scf  files using the Tag 
Configuration Editor. For more information about the 
BridgeVIEW Engine, see the section What Is the BridgeVIEW 
Engine Manager? in this chapter.
me System Guide
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Security»Access Levels Opens a utility you can use to add, remove, and modify access
levels in your BridgeVIEW system. If user accounts are defined i
your system, you must have Administration privileges to edit the
list of access levels. For more information about security and 
access levels, see Chapter 6, BridgeVIEW Security.

Security»Change Password Opens a dialog box to change the current user password. You m
be logged in to change your password. For more information abo
security and passwords, see Chapter 6, BridgeVIEW Security.

Security»Edit User 
Accounts

Opens a utility you can use to create and edit user accounts in yo
BridgeVIEW system. If user accounts are defined in your system
you must have Administration privileges to create and edit user
accounts. For more information about security and user accoun
see Chapter 6, BridgeVIEW Security.

Security»Login Opens a dialog box you can use to log in to the system. For mo
information about security, see Chapter 6, BridgeVIEW Security.

Security»Logout Opens a dialog box you can use to log out of the system. For mo
information about security, see Chapter 6, BridgeVIEW Security.

Security»Privileges Opens a utility you can use to view your access privileges. For 
more information about security and access levels, see Chapter
BridgeVIEW Security.

Server Tools»Server 
Browser

Launches the Server Browser. You can use the Server Browser
view information about the BridgeVIEW device servers. For more
information about the Server Browser, see Chapter 7, Servers.

Tag»Browser Launches the Tag Browser. You can use the Tag Browser to vie
information on all of the tags in the currently-loaded .scf  file. 
If the BridgeVIEW Engine is not running, you can use the Tag 
Browser to load a different .scf  file. For more information about 
the Tag Browser, see the section What Is the Tag Browser? in 
this chapter.

Table 2-1.  BridgeVIEW Project Menu Items (Continued)

Project Menu Item Description
BridgeVIEW Run-Time System Guide 2-2 © National Instruments Corporation
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What Is the BridgeVIEW Engine Manager?

When you run any G application that accesses the BridgeVIEW Real-T
Database, the BridgeVIEW Engine launches automatically, opening ei
the configuration (.scf ) file you edited most recently or the one your 
application selects programmatically.

Launching the BridgeVIEW Engine brings up the Engine Manager 
display, shown in Figure 2-1. The Engine Manager is a window into th
BridgeVIEW Engine, through which you can control some of the behav
of the BridgeVIEW Engine.

Figure 2-1.  Engine Manager Display

Table 2-2 provides a description of each of the fields in the Engine 
Manager dialog box. This table provides basic information about the 
Engine Manager dialog box options. For a more complete understand
of how or why you might use the Engine Manager in a BridgeVIEW 
application, you must understand how to configure tags. See Chapter
Tag Configuration.

Tag»Configuration Launches the Tag Configuration Editor. You can use the Tag 
Configuration Editor to define all of the tags in your BridgeVIEW 
system. Also, you can configure other Engine parameters in the
Tag Configuration Editor. For more information about the Tag 
Configuration Editor, see Chapter 3, Tag Configuration.

Tag»Monitor Launches the Tag Monitor. You can use the Tag Monitor to 
monitor the value, alarm state, and status of all tags in the syste
as well as write the value to an output or input/output tag. The Ta
Monitor launches the BridgeVIEW Engine if it is not already 
running. For more information on the Tag Monitor, see the What 
Is the Tag Monitor? section in this chapter.

Table 2-1.  BridgeVIEW Project Menu Items (Continued)

Project Menu Item Description
© National Instruments Corporation 2-3 BridgeVIEW Run-Time System Guide
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Table 2-2.  Engine Manager Field Descriptions

Field Description

Engine Status Displays the current status of the BridgeVIEW Engine—whether launchin
running, or stopped. 

Log Historical 
Data

Turns on or off logging of historical data to file. This button is pressed 
automatically if you selected Start logging on system start-up in your 
configuration file. If you do not have a valid event log path configured, 
or do not have a printer configured, this checkbox is disabled. 

Log Events Turns on or off logging of alarms and events to file. This button is pressed
automatically if you selected Start event logging on system start-up in your 
configuration file. If you do not have a valid event log path configured, this
checkbox is disabled.

Print Events Turns on or off printing of alarms and events to your line printer. This butto
is pressed automatically if you selected Start printing on system start-up in 
your configuration file. If you do not have a printer configured, this checkbo
is disabled.

Run/Stop Engine Starts the BridgeVIEW Engine, or stops the BridgeVIEW Engine and shut
down any loaded servers. 

Quit Engine Closes and exits the BridgeVIEW Engine process. 

Enable Error 
Dialog

Enables or disables the showing of the Error dialog box. If this box is checke
a System Error Display dialog box pops up for you to acknowledge the eve
when a system error occurs. 

Server Browser Launches the Server Browser Utility. With this utility, you can see the serve
in your system, including OPC servers; view server information; and displa
the server front panel if the server is running (VI-based servers only).

Show/Hide 
System Event 
Display

Shows or hides the System Event Display.
BridgeVIEW Run-Time System Guide 2-4 © National Instruments Corporation
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The Engine Manager shows the current state of the Engine, and has a
System Event Display that shows the following:

• BridgeVIEW System Events 

• When the Engine started and stopped 

• Which servers have been launched 

• Any System Errors that have occurred 

This information is written to the current BridgeVIEW System Log File
found in the BridgeVIEW\Syslog  folder. Figure 2-2 shows how the 
Engine Manager Display looks when the Show System Events Display 
button is enabled.

Figure 2-2.  Engine Manager with System Events Displayed

Once the BridgeVIEW Engine is launched and running, the Engine 
Manager is minimized and appears in your Windows taskbar. Click on
the BridgeVIEW Engine icon in your taskbar to bring up the Engine 
Manager display.

You can leave the BridgeVIEW Engine Manager display minimized unle
you want to start or stop the Engine, or start or stop historical logging, e
logging and printing, view system events, or view server information.

From the Engine Manager, you can reach the Server Browser utility, sh
in Figure 2-3, by pressing the Server Browser… button. With this 
utility, you can see the servers in your system, view server information
and display the server front panel if the server is running (VI-based 
servers only).
© National Instruments Corporation 2-5 BridgeVIEW Run-Time System Guide
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The Server Browser is shown in the following illustration. For more 
information about device servers, see Chapter 7, Servers.

 

Figure 2-3.  Server Browser

The Show Server User Interface button appears on the Server 
Browser dialog box only when you invoke the Server Browser from 
the Engine Manager.

If your application does not shut down within a few seconds after you 
close the BridgeVIEW Engine Manager, BridgeVIEW displays a dialog 
box notifying you to shut down your HMI application. You can ensure 
your application shuts down when the Engine shuts down by monitoring 
the shutdown output of any Tags or Alarms VI or the Engine Status VI 
in your diagram.

What Are System Errors and Events?

System errors are conditions on a system level (as opposed to a per tag
basis) that result in problematic functioning of the BridgeVIEW system
When a system error occurs, BridgeVIEW prompts the user with a dia
box. You can turn this dialog box on or off.

System events are changes in the system that cause a change in behavior 
that is not problematic. These include events reported by utilities such as 
the Tag Configuration Editor.

Detailed system error and event messages are logged to a system log file. 
The messages are written to an ASCII file with a .log  extension in the 
BridgeVIEW Run-Time System Guide 2-6 © National Instruments Corporation



Chapter 2 BridgeVIEW Environment
SYSLOG directory. BridgeVIEW automatically creates this directory, if 
it does not exist already. The system log file names take the format, 
YYMMDDHHMM.log where YY = year, MM = month, DD = day, HH= hour, 
andMM = minute.

What Is the Tag Browser?

With the Tag Browser utility, shown in Figure 2-4, you can view the 
general configuration of all configured tags in the system. Launch the 
Tag Browser by selecting Project»Tag»Browser. 

A list of all the configured tags appears in the listbox. Select a tag by 
clicking on it, and the configuration for that tag displays on the right. 
For more detailed tag configuration information or to learn how to edit 
a tag configuration, see Chapter 3, Tag Configuration.

Figure 2-4.  Tag Browser Utility
© National Instruments Corporation 2-7 BridgeVIEW Run-Time System Guide
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The following table describes each of the fields in the Tag Browser Util
dialog box. 

Table 2-3.  Tag Browser Field Descriptions

Field Description

Configuration File Displays the name of the configuration file you are browsing.

Browse If the BridgeVIEW Engine is not running, press this button to select a 
different configuration file.

Location Displays the full path of the directory containing the configuration file you 
are browsing.

Engine Status Displays the current state of the BridgeVIEW Engine, whether it is loaded
running or stopped.

Configured Tags Displays the list of all tags currently configured. Click on a tag to display th
tag configuration on the right. 

Edit Edits the selected tag in the Tag Configuration Editor.

Name Displays the name of the currently selected tag. Use this display to select 
copy the tag name and paste it into your HMI diagram.

Description Displays the description field for the currently selected tag.

Type Displays the type of the currently selected tag: analog, discrete bit array, o
string.

Access Displays the access rights for the currently selected tag: Memory, Input, 
Output, or Input/Output.

Group Displays the group to which the selected tag belongs. If this field is blank, t
tag does not belong to a group.

Server Displays the name of the server connected to the currently selected tag. 
If the tag is a memory tag, no server is associated with it.

I/O Group Displays the name of the I/O group for the currently selected tag. If the tag
a memory tag, no server or I/O group is associated with it.

Item Displays the name of the item connected to the selected tag. If the tag is 
memory tag, no server, I/O group, or item is associated with it.

Alarms Enabled Displays whether alarms are enabled for the selected tag. 

Auto Ack Displays whether alarms for the selected tag are acknowledged automatic
BridgeVIEW Run-Time System Guide 2-8 © National Instruments Corporation



Chapter 2 BridgeVIEW Environment

he 

re 

m 
lue to 
 

 

r 

 

If the BridgeVIEW Engine is loaded, you can view the tags currently 
loaded with the Tag Browser. If the BridgeVIEW Engine is not loaded, t
Tag Browser displays the currently loaded .scf  file. Use the Browse… 
button to change the .scf  file.

The Tag Browser is a useful tool to see how the tags in your system a
configured. You also can use the Tag Browser to change the loaded 
configuration file.

What Is the Tag Monitor?

With the Tag Monitor, you can monitor the value, unit, timestamp, alar
state, and status for selected tags in the system, as well as write the va
an output or input/output tag. You launch the Tag Monitor by selecting
Project»Tag»Monitor. When you first launch the Tag Monitor, a tag 
selection dialog box displays all the tags configured in the currently 
selected tag configuration file. For more information about configuring
tags, refer to Chapter 3, Tag Configuration.

Full Scale Displays the full scale engineering value for the tag. This is displayed for 
analog tags only.

Zero Scale Displays the zero scale engineering value for the tag. This is displayed fo
analog tags only.

Units Displays the engineering unit for the tag. This is displayed for analog tags
only.

Table 2-3.  Tag Browser Field Descriptions (Continued)

Field Description
© National Instruments Corporation 2-9 BridgeVIEW Run-Time System Guide
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The following figure shows the Tag Monitor. 

Figure 2-5.  Tag Monitor Utility

Note Selecting the Tag Monitor from the Project menu automatically launches the 
BridgeVIEW Engine if it is not running already.

Tag information is shown in a table format, sorted by tag name. When a
has a non-zero tag status, the Status column indicates if the tag status
Warning  or Error . 
BridgeVIEW Run-Time System Guide 2-10 © National Instruments Corporation
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The following table describes the fields and captions in the Tag Monito
Utility.

The Status Details dialog box, shown in Figure 2-6, displays a summar
of the status for each tag in the system. Tags that have a warning are 
highlighted in blue, and tags in error are red. BridgeVIEW provides a 
description of the error or warning when possible. Internal codes are 
reported by BridgeVIEW; the Server Code is returned by the server 
of the tag. Clicking on Status Details is equivalent to selecting 
Tag Monitor»Status Details….

Table 2-4.  Tag Monitor Utility Field Descriptions

Field Descriptions

Tag Display Table Alphabetically lists the information for tags you have selected, including th
value, units, timestamp, status, alarm state and error, if any. For writable
tags, which have a yellow background, clicking on the tag's value field 
brings up the Write to Tag dialog box, that lets you specify a new value for
that tag. For bit array tags, the radix of the input value must be the same
that of the tag's value field in the Tag Display Table. Click OK  to write the 
value in Value to Input and exit the dialog box. Click Apply  to write the 
value in Value to Input and keep the dialog box open.

Trigger Tag Displays which tag, if any, you have selected to trigger refreshing of the T
Display Table. If you selected a tag to trigger refreshing of the Tag Displa
Table, the display refreshes when that tag changes value in the databas
the monitor timeout period is exceeded, whichever occurs first.

Monitor Timeout 
(sec)

Displays the time interval in seconds that the Tag Display Table is 
configured to refresh or update. If no trigger tag is selected, the display 
updates at this time interval. Otherwise, the Tag Display Table refreshes
when the tag changes or the timeout interval is exceeded, whichever 
occurs first.

Status Details Brings up the Status Details dialog box, shown in Figure 2-6, that displays 
a summary of the status for each tag in the system.

Select Tags to 
Monitor

Brings up the Select Tags to Monitor dialog box, shown in Figure 2-7, that 
lets you select which tags to monitor and configure how often to refresh t
monitor display.
© National Instruments Corporation 2-11 BridgeVIEW Run-Time System Guide
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Figure 2-6.  Status Details Dialog Box

With the Select Tags to Monitor dialog box, shown in Figure 2-7, you can
select which tags to monitor and configure how often to refresh the mon
display. The Available Tags list box shows the tags not displayed in the 
Display Table. By default, the timeout is set to 1.00 second. This contr
how often the Tag Display Table is refreshed. By default, no tag is sele
to trigger a refresh of the Tag Display Table. You can select a tag to trig
a refresh of the Tag Display Table from the Trigger Tag Ring. Then, the 
Display Table refreshes each time that tag is updated in the database
when the timeout interval elapses, whichever occurs first. Clicking on 
Select Tags to Monitor is equal to selecting Tag Monitor»Select Tags….

 

Figure 2-7.  Select Tags to Monitor Dialog Box
BridgeVIEW Run-Time System Guide 2-12 © National Instruments Corporation
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Select Tag Monitor»Preferences to bring up the Tag Monitor 
Preferences dialog box, shown in Figure 2-8, which lets you choose ho
certain types of tags are displayed. You can control how the displayed
precision for analog tags by modifying the Digits of Precision field. For 
array tags, the values can be in binary, octal, or hexadecimal format. T
possible values for discrete tags can be 0 and 1 corresponding to Num
Value; or a set of user-customizable strings, one equivalent to TRUE a
the other to FALSE. Check the Monitor Same Tags in Next Session check 
box to keep the same tag list for the next time you launch the Tag Mon

Figure 2-8.  Tag Monitor Preferences Dialog Box
© National Instruments Corporation 2-13 BridgeVIEW Run-Time System Guide
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How Do You Access Online Help?

The system developer might have included online help for your applica
software. Consult the documentation for your application or check with 
system developer about the availability of application-specific online he

BridgeVIEW Run-Time System Online Reference is available online by 
selecting Help»Online Reference or by double-clicking the bridge.hlp  
file included with the BridgeVIEW Run-Time System package. 
BridgeVIEW Run-Time System Guide 2-14 © National Instruments Corporation
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Tag Configuration

This chapter describes tags, the Tag Configuration Editor, how 
you edit tags within the BridgeVIEW system. Before you can run a 
BridgeVIEW application, you must specify a tag configuration.

What Is a Tag?

A tag is a data value in the BridgeVIEW Engine. Tags can be used to 
monitor an I/O point, to store a result of a calculation based on other t
or to monitor a tag on another BridgeVIEW Engine. A memory tag is a tag 
used for user-specified calculations, and a network tag is a tag remotely 
connected to any type of tag on another BridgeVIEW Engine.

This section defines a tag in terms of its attributes and describes how 
attributes affect Engine operations. You can define and configure tags 
the Tag Configuration Editor, described later in this chapter.

Tag Attributes
The BridgeVIEW Engine manages the Real-Time Database (RTDB) wh
contains information about all the tags in the system. The Engine han
the following tasks:

• Communicates with device servers or other BridgeVIEW Engines

• Scales tag values

• Tracks alarms and events associated with tags, system errors and
events

• Logs tag values, alarms, events and system messages to disk

You can customize these tasks by configuring each tag with the Tag 
Configuration Editor. The Tag Configuration Editor displays five 
categories of attributes for each tag: general information, connection, 
operations, scaling, and alarms.

Operations, scaling, and alarms attributes describe how the Engine han
a tag’s data. Each attribute can be further classified by the effect on a 
running Engine from changing the attribute.
me System Guide
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General Attributes
General attributes include data type, maximum length for string and bi
array tags, and the name, description, and tag group of the tag. The 
BridgeVIEW system supports four types of tags: analog, discrete, strin
and bit array. These types differ by the inclusion of attributes within th
operations, scaling, and alarm categories. The tag type is fixed when 
created. You must use the tag name to identify a particular tag. For 
information on how to configure the general attribute of a tag, see the 
General section later in this chapter.

Connection Attributes
I/O connection attributes describe where the Engine sends or receives
values for the tag and how to access that data. These tags have access
of input, output or input/output. To configure the I/O connection attribut
of a tag, refer to the Connection section later in this chapter.

Memory tags are not connected to a real world I/O point. Memory tags
provide more complex monitoring, alarming, or control. For more 
information about memory tags, see the What Is a Memory Tag? section 
later in this chapter.

Operation Attributes
Operation attributes describe additional functionality that the Engine 
performs on a tag or its values. These operations include tasks such a
setting initial values and enabling logging operations. To configure 
the operation attributes of a tag, refer to the Operations section later in 
this chapter.

Scaling Attributes
Scaling attributes describe what linear scaling function is applied to a t
value. Scaling is useful for converting the range of values from measu
units into a calculated range. Only analog (numeric) and Bit Array tags
have Scaling attributes. To configure scaling attributes of a tag, see th
Scaling section later in this chapter.
BridgeVIEW Run-Time System Guide 3-2 © National Instruments Corporation
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Alarm Attributes
Alarm attributes describe abnormal process conditions for a given tag
Alarms are useful for notifying users of abnormal conditions. For examp
if an analog tag measures the volume of a tank, a HI alarm can be use
indicate that the tank is full and an operator must perform some action
and acknowledge this state before processing can proceed. For informa
on how to configure alarming attributes of a tag, see the Alarms section 
later in this chapter.

Static vs. Dynamic Attributes
Tag attributes are classified as either static or dynamic attributes. Static 
attributes require you to restart the Engine when you change them from
the Tag Configuration Editor. A static attribute change is marked with 
asolid diamond in the Tag Configuration Editor. Examples of static 
attributes are general attributes and I/O connection attributes, such as
server, device, or item.

Dynamic attributes do not require the Engine to restart. The Tag 
Configuration Editor can change a dynamic tag attribute in a running 
Engine. A dynamic attribute change is marked with a hollow diamond in 
the Tag Configuration Editor. Examples of dynamic attributes include 
enabling logging operations, alarm attributes, and some scaling attributes. 

What Is the Tag Configuration Editor?

The Tag Configuration Editor is a tool that assists you in configuring a
the parameters of the BridgeVIEW Engine. The chief component of thi
tool is the configuration of all tags in the system. Other configuration 
components include Alarm and Event Logging, and Historical Logging

Caution Editing or deleting tags might cause your application software to function 
incorrectly. Contact the application developer before making any changes to 
your .scf  file.

To start the Tag Configuration Editor, select Project»Tag» 
Configuration…  from the menu bar of an open VI. Figure3-1 shows 
the Tag Configuration Editor with tanks.scf  loaded.

!

© National Instruments Corporation 3-3 BridgeVIEW Run-Time System Guide
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Figure 3-1.  Tag Configuration Editor

The Tag Configuration Editor records all tag information and Engine 
parameters and stores this information in a BridgeVIEW Configuration
File with the extension .scf  (SCADA Configuration File). The 
BridgeVIEW Engine reads this file to determine all of the configuration
parameters for execution. With the Tag Configuration Editor, you can 
specify the following:

• Tags used in the system 

• File paths for historical data and event logging 

The .scf  file does not contain any information about the VIs in your 
HMI. In fact, it is not specific to a single  application. Multiple user 
applications can run concurrently as long as they use the same set of 
When you launch the Tag Configuration Editor, the last opened .scf  file 
opens automatically.

Note Only one .scf  file can be loaded and running in the BridgeVIEW Engine 
at a time. 

If you edit a .scf  file while the Engine is running and select Save or 
Save As…, a dialog box confirms if you want to update the Engine 
with your latest changes. If you want to update the Engine and any sta
attributes have been changed, the Engine shuts down and restarts. If 
have changed only dynamic attributes in the .scf  file, the Engine is 
updated without restarting.
BridgeVIEW Run-Time System Guide 3-4 © National Instruments Corporation
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Note Communication between the BridgeVIEW Engine and any device server is 
stopped temporarily when the Engine shuts down and restarts.

How Do You Create a Tag?
From the main panel of the Tag Configuration Editor, press one of the
following buttons: Create Analog Tag(s)…, Create Discrete Tag(s)…, 
Create String Tag(s)…, or Create Bit Array Tag(s)…. A separate 
window prompts you to define a new tag. The tag name must be uniqu
within a given configuration (.scf ) file. Select OK  on the pop-up window 
when you finish creating the new tag, or Create New Tag to finish creating 
the new tag and create another tag of the same type. Any changes ar
written to disk until you select Save from the File menu.

Note For Run-Time System users, creating new tags is unlikely because you canno
modify your application. However, you might find it necessary to modify the 
properties of a tag.

How Do You Edit a Tag?
From the main panel of the Tag Configuration Editor, select one or mo
tags from the tags listed and press the Edit Tag(s)... button. A separate 
window displays the attributes for the tags you select, which you can t
edit. When you finish editing a tag, select OK  to save your changes and 
return to the main panel, Edit Next Tag to save your changes and go on 
to the next tag, orCancel to discard your changes and return to the mai
panel. Selecting Cancel only cancels the changes made to the current ta
Any changes you make are not permanent until you save the configura
file.

You also can use a spreadsheet to edit multiple tags. Use File»Export… to 
export the tag information to a spreadsheet file, edit the fields, and then
File»Import…  to import the tag configuration information from the edite
spreadsheet file. For more information, see the How Do You Use 
Spreadsheet Files for Tag Configuration? section later in this chapter.

How Do You Delete a Tag?
To delete a tag from a configuration, select the tag(s) from the main pa
of the Tag Configuration Editor and press the Delete Tag(s) button, and 
then save the SCF. Tags that will be deleted when you save the SCF 
marked with a trashcan symbol. The Delete Tag(s) button also serves as an
Undelete Tag(s) button if all selected tags have a trash can symbol. If y
decide you want to keep one or more deleted tags, select those tags a
press the Undelete Tag(s) button.
© National Instruments Corporation 3-5 BridgeVIEW Run-Time System Guide
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Note If you delete a tag and save the .scf  file, the tag and its configuration information 
are removed from the .scf  file. You still can retrieve historical and event 
information about the tag, but information such as the tag description, units, 
range, and alarm settings is lost.

What are Network Tags?
BridgeVIEW makes it easy to create distributed applications so more t
one computer can be involved in an HMI application.

A BridgeVIEW server is a computer that allows tags configured in the 
current .scf  file to be accessed by other machines connected to the server 
via a network. The server machine may or may not have an HMI running 
on it. In order for a machine to function as aBridgeVIEW server, the 
Engine must use an.scf  file that has the Allow Network Access option 
enabled.

A BridgeVIEW client is a computer that gets its data through tags from o
or more BridgeVIEW servers. Tags remotely accessed from BridgeVIEW
servers are network tags. An .scf  file for a BridgeVIEW client can have 
network tags from multiple BridgeVIEW servers. However, a BridgeVIEW 
client .scf  can import network tags from only one .scf  file per server 
machine.

A BridgeVIEW server can also act as a client and get its data from othe
BridgeVIEW server machines, as shown in the illustration below.

Figure 3-2.  Flowchart of Server/Client Interaction

BridgeVIEW Servers

BridgeVIEW Clients

BridgeVIEW
Server/Client
BridgeVIEW Run-Time System Guide 3-6 © National Instruments Corporation
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How Do You Add Network Tags?
On the BridgeVIEW server, all tags in an allowed .scf  file can be viewed 
by another BridgeVIEW system by opening the Tag Configuration Edi
and selecting Configure»Allow Network Access. The tags are not shared
until the .scf  file is saved on the server side.

On the BridgeVIEW client, open the Tag Configuration Editor and sele
File»Import Network Tags…. The Select Tags for Network Import 
dialog box, shown in Figure 3-3, allows you to browse the network for 
.scf  file and select tags you wish to import. After selecting the tags yo
wish to import, save the .scf  file on the BridgeVIEW client and start the
BridgeVIEW Engine.

Figure 3-3.  Select Tags for Network Import Dialog Box

How Do You Set Default Values for Tag Configuration Fields?
You can simplify the tag configuration process by defining default 
values for several fields. These default values are then used when you
create tags automatically, such as with the Configuration Wizard or by
importing. For example, you might want to set the default toLog Data 
or Log Events, or set the log deadband to a particular value by default.
You can set default values for tag parameters using the Set Default 
Parameters dialog box, shown below. To access this dialog box, 
selectConfigure»Default Parameters…. 
© National Instruments Corporation 3-7 BridgeVIEW Run-Time System Guide
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The default values apply when creating a new tag, importing a tag from
the server registry, or importing a tag from a spreadsheet. In the case 
spreadsheet, a value in the spreadsheet overrides the default value fo
the field. For more information about the individual fields, see the How Do 
You Configure Tags? section in this chapter.

How Do You Use Spreadsheet Files for Tag Configuration?
With the Tag Configuration Editor, you can export tag configuration 
information to spreadsheet files, and import tag configuration informati
from spreadsheet files. The files are tab-delimited text (.txt ) files.

Select File»Export… to save the file as a tab-delimited .txt  file. When 
you select Export… , a dialog box prompts you to select and order the 
fields you want in your spreadsheet file. If you intend to edit the 
spreadsheet file and then import the edited information back into the T
Configuration Editor, select the All >>  button to select all available fields.
BridgeVIEW Run-Time System Guide 3-8 © National Instruments Corporation
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For easy viewing and editing in the spreadsheet, press the 
Use Default Order button.

After you edit the file, save it as a .txt  file. Then, from the Tag 
Configuration Editor, select File»Import…  to import the information 
from the spreadsheet file. 

If you use spreadsheet files with the Tag Configuration Editor, it is 
important that you understand the following points:

• If you do not choose all of the fields when exporting your data, you
lose configuration information when you import it back to the Tag 
Configuration Editor. 

• You might choose to export a subset of information, and then rely 
on tag default parameters when you import the data back in to the
Configuration Editor. However, each row in the spreadsheet file m
contain the tag name and data type fields, or the import mechanis
cannot read it.

• Some configuration parameters, such as Historical Logging 
Configuration and Event Configuration, are inherited from the 
currently open .scf  file when you import spreadsheet data.

• When importing, you can append the imported tags to the current
.scf file.

Note If the tag name and data type fields are missing, the File»Import…  option does 
not work on the spreadsheet file. 
© National Instruments Corporation 3-9 BridgeVIEW Run-Time System Guide
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How Do You Configure Tags?

When you configure a tag with the Tag Configuration Editor, you defin
several attributes for the tag. You can separate these attributes into fiv
categories: general, connection, operations, scaling, and alarms. Each
these categories is explained in detail later in this section. 

If you import tag configuration information from a spreadsheet, follow 
the same format in your spreadsheet as indicated in the Attribute column 
of each of the tables listed above. For more information about using 
spreadsheets, see the How Do You Use Spreadsheet Files for Tag 
Configuration? section earlier in this chapter.

Data Type
Configuration of a tag varies slightly depending on the data type. 
The following sections discuss the details of tag configuration for each
data type.

Analog Tags
An analog tag is a continuous value representation of a connection to 
a real-world I/O point or memory variable. This type of tag can vary 
continuously over a range of values within a signal range.

Use an analog tag when you want to express a continuous value 
(for example, 0 to 100).

Discrete Tags
A discrete tag is a two-state (ON/OFF) value representation of a 
connection to a real-world I/O point or memory variable. This type of 
tag can be either a 1 (TRUE) or a 0 (FALSE).

Use a discrete tag when you want to express a two-state (ON/OFF) value.

Bit Array Tags
A bit array tag is a multi-bit value representation of a connection to a 
real-world I/O point or memory variable. This type of tag can be compris
of up to 32 discrete values.

Use a bit array tag when you have a multi-bit value in which each of the 
bits represents a flag or single value that is turned on or off. The maximum 
length of a bit array tag is 32.
BridgeVIEW Run-Time System Guide 3-10 © National Instruments Corporation
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String Tags
A string tag is an ASCII character representation of a connection to a 
real-world I/O point or memory variable.

Use a string tag when you have binary information or an ASCII value. 
For example, you might use a string tag to obtain values from a bar code 
reader, or if you have data that does not fit into any other data type.

General
The general attributes of a tag include the name of the tag you are 
configuring, the group name to use for the tag, a description of the tag
and the maximum length for string and bit array tags. Figure3-4 shows 
the General tab of the Tag Configuration dialog box.

Figure 3-4.  General Attributes Dialog Box

Table 3-1 provides descriptions of the general attributes of a tag. 
For tag attribute information about the other configuration categories, 
seeTables 3-2, 3-4, 3-5, and 3-7.
© National Instruments Corporation 3-11 BridgeVIEW Run-Time System Guide
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Connection
You associate a tag with its real-world I/O point by assigning it a Server, 
I/O Group , and Item in the Connection tab of the Tag Configuration 
dialog box, shown in Figure 3-5. If an I/O Group does not already exist
the server, you must create one before you can select or enter an item
the tag. The I/O Group is user-defined and provides you with a place t
configure the rate and deadband for an item. For IAK and VI-based serv
you select the device as part of the I/O group configuration. For OPC 
servers, the I/O group conforms to an OPC group.

When you edit a tag, use the ring inputs to assign values to the tag. Us
Create…, Edit… , and Delete buttons to configure I/O Groups and Items
For more information about device servers, see Chapter 7, Servers.

Table 3-1.  General Configuration Attributes

Attribute
Applies to 
Data Types Description

 Tag Name all Determines the name of the tag you are configuring. Always refe
to a tag by its name. Tag names are not case sensitive and ca
include any combination of printable characters (including 
space) with the exception of “/” (forward slash) and “\” 
(backslash).

Tag Group all Determines the group name to use for this tag. You can use 
groups to assist in alarm management and reporting and to he
organize tags in an application.

Tag 
Description

all Provides a description of the tag.

Maximum 
Length

string, 
bit array

Determines the maximum number of bits in the bit array. 
The length is between 1 and 32 for bit array tags. String tags 
can be of any length.
BridgeVIEW Run-Time System Guide 3-12 © National Instruments Corporation
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Figure 3-5.  Tag Connection Dialog Box

If a device server does not appear in the server name list, you must ru
configuration or registration utility for your server before BridgeVIEW ca
access the server.

Table 3-2 provides descriptions of the connection attributes, and indica
the data types to which each attribute applies. For tag attribute informa
about the other configuration categories, see Tables 3-1, 3-4, 3-5, or 3
© National Instruments Corporation 3-13 BridgeVIEW Run-Time System Guide
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I/O Group Configuration
I/O Groups are used to configure item rate and deadband for items of
server and to select a specific device, if the server uses devices. For se
that support resource configuration, you also can use I/O groups to 
configure devices and communication resources. For OPC servers, an
group conforms to the concept of an OPC group, which is user-defined
controls timing. An I/O Group is associated with only one server and, if t

Table 3-2.  Connection Configuration Attributes

Attribute
Applies to 
Data Types Description

Data Type all Determines the data type of the tag you are configuring. 
BridgeVIEW tags can be analog, discrete, bit array, or string. 

Tag Access all Determines the access rights for a tag. Tags can have access
rights of Memory, Input only, Output only, or Input/Output. 
Memory tags are not directly connected to real-world I/O points
You can use memory tags to monitor and control calculated 
values and enable historical trending and alarming on these 
values. Input only, Output only, and Input/Output tags are 
connected to real-world I/O points according to the Server, 
Device, and Item fields. 

Server all Determines the device server that manages the communication
the tag value. If the tag is a memory tag, this attribute is not use

I/O Group all Determines the I/O Group to use for this tag. Select the I/O Grou
this tag uses. The I/O Group is associated with the server. At lea
one I/O Group must be created for the server in order to configu
a tag to use a server item. If the tag is a memory tag, this attribu
is not used.

Item Name 
Filter

all Determines the string to filter the list of configured items. If the
tag is a memory tag, this attribute is not used.

Item all Determines the register, channel, or item on the device for this
tag. This might be a PLC register, a data acquisition channel, a
OPC item ID, or a DDE item, depending on the server used fo
this tag. If the tag is a memory tag, this field is not used.

Access Path all Determines the access path for the selected server. If the tag i
memory tag or if the server does not have access paths, this 
attribute is not used.
BridgeVIEW Run-Time System Guide 3-14 © National Instruments Corporation
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server uses devices, with only one device. A server can have multiple
Groups associated with it. 

I/O Group Configuration Options

The Create… button invokes the I/O Group Configuration dialog box, 
which you can use to specify group name and timing parameters. For 
servers that support resource configuration, you also can use this dialog
to select and configure devices and to configure communication resou

The Edit…  button invokes the I/O Group Configuration dialog box for 
the I/O Group selected in the I/O Group list. Use this dialog box to cha
the group name and timing parameters. For servers that support resou
configuration, you also can use this dialog box to select and configure
devices and to configure communication resources.

The Delete button invokes a confirmation dialog box. If confirmed, 
the I/O Group is deleted from the server configuration. Deleting an 
I/O Group does not delete the device and communication resource 
from the server configuration.

 

Figure 3-6.  I/O Group Configuration Dialog Box
© National Instruments Corporation 3-15 BridgeVIEW Run-Time System Guide
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Table 3-3 provides descriptions of the operations that can be performe
an I/O Group. For information about other opeations that can be perform
on an I/O Group, see Table 3-2.

 

Server Configuration Options

Use this group of fields to configure and select server resources. Som
or all fields in this group might not be used depending on the server 
type. An IAK server has both Device and Communication Resource 
configuration capabilities.

Table 3-3.  I/O Group Configuration Attributes

Attribute  Description

I/O Group Name Determines the name of the I/O Group you are configuring. I/O Grou
names are not case sensitive and can include any combination of 
printable characters (including spaces) with the exception of “/” 
and “\”.

I/O Group Description Provides a description for the I/O Group.

I/O Group
Update Rate (secs)

Determines the rate for the server to update the item value in the 
engine for all tags using the I/O Group. The server can have other 
configuration options that determine the actual update rate. This is
the rate at which BridgeVIEW requests all tags configured with this
update rate be updated.

I/O Group Deadband
(% of range)

Determines the deadband for the server to update the item value in 
engine for all tags configured with the I/O Group. Use 0% if you do
not want the server to apply deadbands to the item.

Note: Not all servers support deadbands, and some might ignore th
value.

Server Name Indicates the Server Name associated with the I/O Group you are 
configuring.

Communication Resource Provides a means to configure (create, edit, or delete) a 
communication resource. This field is valid only for IAK servers.

Device Determines a specific device used by the I/O Group and Server for th
tag. If the associated server is an OPC Server, this attribute is not us

Device Comm Resource Indicates the communication resource associated with the selected
device. This field is valid only for IAK servers.
BridgeVIEW Run-Time System Guide 3-16 © National Instruments Corporation
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Communication Resource Configuration Options

For IAK servers, use the Create… button to invoke a new, untitled 
IAK Create Communication Resource Configuration dialog box. 
This configuration option is not used for other classes of servers.

For IAK servers, use the Edit…  button to invoke the IAK Edit 
Communication Resource dialog box for the currently selected 
communication resource. This configuration option is not used 
for other classes of servers.

For IAK servers, use the Delete button to remove the selected 
communication resource from the server configuration. This 
configuration option is not used for other classes of servers. 

Device Configuration Options�Configuring Device Names

This option is available for servers that allow users to configure device
names. OPC Servers do not use device names. For DDE Servers, the
device name is used to specify the DDE application and topic. See the How 
Do You Connect a Tag to a DDE Server? section later in this chapter for 
more information.

The Add… button invokes the Device Entry dialog box, which you can 
use to add a new device name for a selected server. If the server does
support device configuration, or if the selected device name is not vali
this button is disabled.

The Edit…  button invokes the Device Entry dialog box, which you can u
to edit an existing device name for a selected server. If the server doe
support device configuration, or if the selected device name is not valid,
button is disabled.

The Delete button invokes a confirmation dialog box. If confirmed, 
the selected device name is removed from the device list. If the server 
not support device configuration, or if the selected device name is not va
this button is disabled.

Device Configuration Options�Configuring Device Resources

This option is supported by servers that allow users to configure 
device resources.

Use the Create… button to invoke a new, untitled Create Device 
Configuration dialog box. The options in this dialog box vary dependin
on the type of server. If the server does not support device configuratio
this button is disabled.
© National Instruments Corporation 3-17 BridgeVIEW Run-Time System Guide
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Use the Edit…  button to invoke the Edit Device Configuration dialog bo
for the device currently selected in the device list. The options in this dia
box vary depending on the type of server. If the server does not suppo
device configuration, this button is disabled.

Use the Delete button to remove the selected device from the server 
configuration. If the server does not support device configuration, 
this button is disabled.

Item Configuration Options
Use the Item Connection fields in the Connection tab (see Figure 3-5) 
to select and configure the item and access path (for certain OPC Ser
only) for a tag.

Configuring Item Names

This option is available for servers that allow users to configure 
item names.

The Add… button invokes the Item Entry dialog box, which you can use
add a new item for a selected server. If the server has access paths, yo
can use this dialog box to add an access path. If the server does not su
item configuration, this button is disabled.

The Edit…  button invokes the Item Entry dialog box, which you can us
to edit an existing item name for a selected server. If the server has ac
paths, you also can edit an access path. If the server does not suppor
configuration, or if the selected item is not valid, this button is disabled

The Delete button invokes a confirmation dialog box. If confirmed, the 
selected item is removed from the item list. If the server has access pa
the selected access path is removed from the access path list. If the s
does not support item configuration, or if the selected item is not valid
this button is disabled.

Configuring Item Resources

This option is supported by servers that allow users to configure 
item resources.

The Create… button invokes a server-dependent configuration dialog bo
which you can use to configure a new item for a selected server. If the se
does not support item configuration, this button is disabled.
BridgeVIEW Run-Time System Guide 3-18 © National Instruments Corporation
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The Edit…  button invokes a server-dependent configuration dialog box
which you can use to edit the configuration of the selected item. If the 
server does not support item configuration, or if the selected item is no
valid, this button is disabled.

The Delete button invokes a confirmation dialog box. If confirmed, 
the selected item is removed from the server configuration.

The Browse… button, which only applies to OPC Servers that support 
browsing, invokes the Browse OPC Server dialog box. Use this button
to browse the list of available items and select an item and associated
access path.

What Is a Memory Tag?
Memory tags are tags not connected directly to I/O points. They exist on
in the BridgeVIEW RTDB. To configure a memory tag, set the Access 
Rights of a tag to Memory.

Note If you are a Run-Time System user, creating new tags is unlikely because you
cannot modify your application. However, you might find it necessary to modify
the properties of a tag.

When Should You Use a Memory Tag?

Use memory tags when you want to perform alarm calculations, 
or log historical data and event information on data that is either a 
software-generated value or a combination of values from different 
I/O tag readings.

How Do You Automatically Generate 
Tags from Server Information? 
Use the Configuration Wizard to create tags from the server informatio
The Configuration Wizard is useful if you want the BridgeVIEW Engine
to monitor a large number of the I/O points in your system. To invoke 
the Configuration Wizard, press the Configuration Wizard  button on the 
main screen of the Tag Configuration Editor or select Edit»Configuration 
Wizard… . For more information on servers, see Chapter 7, Servers.

When you run the server configuration utilities for the servers on your 
system, you can define devices and items for the I/O points the server
monitor and control. You can automatically create tags from these item
with the Configuration Wizard. When the tags are created, the tag nam
data type, I/O group, I/O connection, and scaling parameters are 
© National Instruments Corporation 3-19 BridgeVIEW Run-Time System Guide
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determined by the server information for each server item. The remain
tag parameters are determined by the default tag parameter settings. 
can edit the default parameters by selecting opening the Tag Configura
Editor and selecting Configure»Default Parameters…. 

For IAK and VI-based servers, server information is read from the 
Common Configuration Database (CCDB). For OPC servers that supp
it, server information is read by browsing the server address space. W
you generate tags, you can either add them to the existing configuratio
selecting Append Tags to SCF? (default mode) or you can create a new
configuration file.

How Do You Connect a Tag to an OPC Server?
You connect to an OPC server just like you connect to the National 
Instruments device servers from the Connection tab of the Tag 
Configuration dialog box. Any OPC servers installed on your machine
are listed in the server name list. Select the OPC server you want to u
Create an I/O Group for the server, specifying the group deadband an
update rate. Select or enter the Item name, which is the same as the O
Server Item ID. You also can select or enter an access path for OPC se
if the server supports that.

How Do You Connect a Tag to a DDE Server?
Although no BridgeVIEW servers are based on Dynamic Data 
Exchange (DDE), you can connect a tag to any existing DDE Server. 
SelectDDE Server as your server in the Connection tab of the Tag 
Configuration Editor to communicate with DDE servers. DDE Servers 
have an Application Name, Topic, and Item. In BridgeVIEW, the devic
in the I/O Group Configuration dialog box is set to appname|topic  
(| = the “pipe” symbol) and the item in the Connection tab of the 
Tag Configuration dialog box is set to item . For example, to connect 
a tag to cell R1C1 (item) of spreadsheet sheet1  (topic) in Excel 
(application), set the tag fields to the following:

Server: DDE Server

Device: Excel|sheet1  (in I/O Group Configuration dialog box)
Item: R1C1

To specify a particular sheet (sheet1 ) within an open Excel file 
(book1.xls ), set the device field to the following:

Device: Excel|[book1.xls]sheet1  (in I/O Group Configuration
dialog box)
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How Do You Define a Group of Tags for Alarming?
While editing a tag, pull down the Tag Group Ring in the General tab of 
the Tag Configuration dialog box. You can select an existing tag group
define a new tag group by selecting Enter New…. To create, edit, or delete
tag group definitions, select Tag Groups… from the Configure menu 
from the main Tag Configuration Editor panel.

You can use tag groups to help define a subset of tags in the system. 
Tag groups are helpful when you want to examine the alarm states for
subset of tags in the system.

Operations
The operations attributes include when to update the tag value in the 
RTDB, whether to log data to a historical file, whether to log events 
associated with the tag, and information about the initial value of the ta
Engine startup. Figure 3-7 shows the Operations Tab of the Analog Tag 
Configuration dialog box. With this section of the dialog box, you can 
inform the BridgeVIEW Engine of what to do with the data in the RTDB

 

Figure 3-7.  Tag Operations Dialog Box
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Table 3-4 provides descriptions of the operations attributes, and indica
the data types to which each attribute applies. For tag attribute informa
about the other configuration categories, see Tables 3-1, 3-2, 3-5, and

 
Table 3-4.  Operations Configuration Attributes

Attribute
Applies to 
Data Types Description

Update 
Deadband

all Determines when the Real-Time Database (RTDB) updates th
value for this tag. It is used to improve system performance an
prevent unnecessary processing of tag values in the RTDB. Th
field is expressed differently for analog, discrete, string, and bi
array tags. For analog tags, Update Deadband is a percent of f
scale. The database updates analog tags only when a new tag
value is different than the currently stored value by at least the
Update Deadband. Use 0% if you want each new value for the t
to be saved in the RTDB. For discrete, string, and bit array tag
Update Deadband is expressed as either Always or On Change.

Log Data analog, 
discrete,
bit array 

Determines whether a tag value is logged to historical files. 

Log Data 
Deadband

analog, 
discrete, 
bit array

Determines when tag values are logged to disk. It is used to 
improve system performance and prevent unnecessary loggin
of data to disk. Like Update Deadband, the field is expressed 
differently for analog, discrete, and bit array tags. For analog 
tags, Update Deadband is a percent of full scale. The 
BridgeVIEW Engine writes new analog tag values to historical
files only when a new tag value is different than the last logged
value by at least the Log Data Deadband. Use 0% if you want 
each new value for the tag to be logged. For discrete and bit 
array tags, Update Deadband is expressed as either Always 
or On Change.

Log 
Resolution

analog Determines the resolution in engineering units for logging a ta
value in the Citadel Historical Database. Tag values are written 
the database in a compressed format with the resolution specifi
by Log Resolution. Use 0.0  if you want the exact value written 
to the Citadel Historical Database. Notice that logging the exac
value requires more time and disk space. The default value 
is 0.1 . 
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What Is Deadband?
In process instrumentation, deadband is the range through which an inpu
signal can vary without initiating an observable change in output signa
Deadband usually is expressed in percent of full scale. Although the te
deadband generally applies only to analog tags, other tag types have 
limited type of deadband. A checkbox allows you to determine if upda
to the RTDB and historical data files should occur with any new data fr
the device server or if the value has changed.

Note The BridgeVIEW Engine performs historical logging and alarm management 
operations based on new values in the RTDB. If you set the Update Deadband too
high, the RTDB might not be updated. This might result in inadequate historica
logging or alarm management.

How Do You Use Deadband to 
Increase Engine Throughput?
The BridgeVIEW Engine uses Update Deadband and Log Deadband 
values to eliminate unnecessary processing on minor data value chan
Deadband allows you to define a significant change. The Engine ignore
operation if the change in data is not considered significant. Deadban
expressed as percent of full scale. For example, if the tag engineering r
is 0 to 200 liters, a deadband of 5% is 10 liters. In addition, through I/O 
group configuration, you can configure a server to apply a deadband to
items associated with that I/O group. Not all servers implement deadba
OPC servers support deadbands.

Log/Print 
Events

all Determines whether events associated with the tag (for example, 
changes in alarm state) are logged to event log files or printed to 
a line printer. 

Set Initial 
Value

all Determines whether an initial value is used for this tag. If Set 
Initial Value is OFF for this tag, the tag value is marked as 
uninitialized until its value is updated. 

Initial Value all The initial value used for this tag when Set Initial Value is ON. 
If the tag is an Output only or Input/Output tag, the BridgeVIEW
Engine sends the Initial Value to the server at Engine startup. 
If the tag is an Input only or Memory tag, the Initial Value is 
stored in the RTDB at startup. 

Table 3-4.  Operations Configuration Attributes (Continued)

Attri bute
Applies to 
Data Types Description
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How Do You Configure a Tag 
to Log Its Data or Events?
While editing a tag, click on the Log Data or Log/Print Events checkbox. 
If you want to log historical data or events, the BridgeVIEW Engine mu
have these processes enabled. To turn them on, open the Engine Ma
and turn on the processes with the panel buttons, or configure the Eng
to turn on these processes automatically at startup by selecting Configure» 
Historical…  or Configure»Events… from the Tag Configuration Editor. 
You also can enable these parameters programmatically with System
that enable event or historical data logging.

How Do You Set Initial Tag Value at Startup?
While editing a tag, select the Set Initial Value checkbox. Then enter the
initial value in the adjacent Initial Value  field.

Scaling
These attributes include what type of scaling to perform on a tag when
communicating with the device server and the expected engineering ra
and units for the tag.

Table 3-5, provides descriptions of the scaling configuration attributes,
and indicates the data types to which each attribute applies. For tag 
attribute information about the other configuration categories, see 
Tables 3-1, 3-2, 3-4, and 3-7.

 
Table 3-5.  Scaling Configuration Attributes

Attribute
Applies to 
Data Types Description

Raw Full 
Scale

analog Determines the full scale (maximum) value used by the server
for a tag. 

Raw Zero 
Scale

analog Determines the zero scale (minimum) value used by the serve
for a tag.

Eng Full 
Scale

analog Determines the full scale (maximum) value used by the 
BridgeVIEW Engine and the user application for a tag. 
Engineering Full Scale must be greater than Engineering 
Zero Scale. 
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The next sections explain how to scale data. Often your application ne
BridgeVIEW to manipulate the raw data used in the device server to p
in a form, called engineering units, suitable for the operators. The follow
sections describe the options for individual data types.

Note There is no scaling for string tags.

Eng Zero 
Scale

analog Determines the zero scale (minimum) value used by the 
BridgeVIEW Engine and the user application for a tag. 
Engineering Zero Scale must be less than Engineering Full Sca

Units analog Determines the engineering units for a tag. Examples include 
degrees Celsius, liters, and kilograms. 

Scaling analog, 
discrete, 
bit array

Determines the type of scaling algorithm to be used for a tag. 
The scaling methods differ according to tag data type. You can
configure analog tags for linear or square root scaling, discrete
tags for invert scaling, or bit array tags for mask scaling. All tag
can be configured for no scaling.

Coerce analog Determines whether to coerce data so that it is valid for the targe
If scaling to output, the value must be within the raw (device 
server) range. If scaling to input, the value must be within the 
engineering (HMI) range. 

Scaling Invert 
Mask

bit array Determines which bits are inverted for a bit array tag. Bits in 
the mask that are 1 are inverted; bits that are 0 are not inverted. 
The default mask is 0, indicating none of the bits are inverted. 
In bit-wise logic terminology, the Engine performs an XOR 
with the Invert Mask to produce the scaled value. 

Scaling Select 
Mask

bit array Determines which bits are used for the bit array tag. Bits in 
the mask that are 1 have their values passed through to the 
RTDB; bits that are 0 are set to zero, regardless of the value 
received from the server. In bit-wise logic terminology, 
the Engine performs an AND with the Select Mask to 
produce the scaled value. 

Table 3-5.  Scaling Configuration Attributes (Continued)

Attribute
Applies to 
Data Types Description
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Analog Tags
You can define the raw range and engineering range for a tag to perfo
simple conversions between the two ranges. The raw range, defined b
Raw Full Scale and Raw Zero Scale, refers to the values used by the 
device server. Engineering range, defined by Engineering Full Scale 
and Engineering Zero Scale, refers to the values used by the BridgeVI
Engine and HMI. Pull down the Scaling ring and select Linear  to enable 
a linear (mx + b) conversion between raw and engineering ranges. Sele
Square Root to enable a square root conversion between the raw and 
engineering ranges. Figure 3-8 shows the Scaling tab of the Analog Tag 
Configuration dialog box. 

Figure 3-8.  Analog Tag Scaling Dialog Box

The following examples describe linear and square root scaling. 
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Example�Linear Scaling

A device server returns a simple voltage from 0 to 5 V. The voltage is 
related to a position sensor, and the real-world position is measured in
centimeters, with 0 V mapped to 50 cm and 5 V mapped to 100 cm.

Configure the tag for raw range from zero (Raw Zero Scale) to five 
(Raw Full Scale). Select Linear, and set the engineering range from 
50 (Eng Zero Scale) to 100 (Eng Full Scale).

Example�Square Root Scaling

A flow meter measures the flow rate of a liquid using a differential press
reading. The device server provides 4–20 mA readings. The actual flo
measured in gallons per minutes (GPM). 4 mA corresponds to 0 GPM
20 mA corresponds to 100 GPM.

Configure the tag for raw range from 4 (Raw Zero Scale) to 20 (Raw F
Scale). Select Square Root Scaling and set the engineering range from 
0 (Eng Zero Scale) to 100 (Eng Full Scale). 

How Do You Assign Units to an Analog Tag?
Use the Engineering Unit ring to assign units to a tag. If the desired uni
is not in the list, select Enter New… and enter the desired unit. In the 
previous example, you select units of GPM.
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Discrete Tags
The only scaling available for discrete tags is invert scaling. Click the 
Invert Data checkbox, shown in Figure 3-9 to advise the BridgeVIEW 
Engine to invert the discrete value when it communicates with the 
device server.

Figure 3-9.  Scaling for Discrete Tag Configuration
BridgeVIEW Run-Time System Guide 3-28 © National Instruments Corporation



Chapter 3 Tag Configuration

 the 
rver 
 the 

s 
Bit Array Tags
Bit array tags can have invert and/or select mask scaling. You can use
invert mask to determine which bits are inverted between the device se
and the BridgeVIEW Engine. You can use the select mask to determine
bits you do not need. Figure 3-10 shows the Scaling tab of the Bit Array 
Tag Configuration dialog box, and Table 3-6 provides examples of tag
configured for bit array scaling.

Figure 3-10.  Scaling for Bit Array Tag Configuration
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Alarms
These attributes include whether to enable alarms, under what 
circumstances a tag is in alarm, the priority level of an alarm, and how
alarms are acknowledged. Each alarm limit has a priority, ranging betw
1 and 15. In BridgeVIEW, 15 is the highest priority and 1 is the lowest

There are two main types of alarms:

• Alarms based on status

• Alarms based on tag values

Configuration for alarms based on tag values is specific to data type. 
Therefore, many alarm attributes apply to only a subset of the BridgeVI
tag data types. For more information about how to access alarm 
information, build alarm summary displays, and retrieve historical 
events files, see Chapter 4, Alarms and Events.

Table 3-6.  Bit Array Scaling Examples

Tag Name Length Raw Value Invert Mask Select Mask Scaled Value

Tag 1 8 0x0F 0x00 0xFF 0x0F

Tag 2 8 0x0F 0x33 0xFF 0x3C

Tag 3 8 0x0F 0x33 0x0F 0x0C

Tag 4 8 0x0F 0x00 0x33 0x30

Tag 5 8 0x0F 0x33 0x33 0x30

Tag 6 16 0x0FF0 0x000F 0x00FF 0x00FF
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Table 3-7 provides descriptions of the alarm attributes, and indicates t
data types to which each attribute applies. For tag attribute information
about the other configuration categories, see Tables 3-1, 3-2, 3-4, or 3

Table 3-7.  Alarms Configuration Attributes 

Attribute
Applies to 
Data Types  Description

Alarms 
Enabled

all Determines whether alarms are enabled for a tag. 

Alarm 
Deadband

analog Determines the amount an analog tag value must diverge from 
alarm limit before the alarm condition returns to normal. Alarm
Deadband is expressed in percent of full scale. 

Auto Ack all Determines how alarms can be acknowledged. If set to Auto Ac
the alarm is acknowledged automatically when the tag value 
returns to the Normal state. If set to User Must Ack, the alarm 
remains unacknowledged until the user acknowledges it, 
regardless of the alarm state. 

Bad Status 
Enabled

all Determines whether to enable Bad Status alarms for the tag.

Bad Status 
Priority

all Determines the value (between 1 and 15) for the alarm priority
for the Bad Status alarm, where 15 represents the highest priori

HI_HI 
Enabled

analog Determines whether to enable HI_HI alarms for a tag. 

HI_HI Limit analog Determines the value, in engineering units, that invokes a 
HI_HI alarm condition. The tag alarm state remains HI_HI 
until the tag value goes below the HI_HI alarm limit minus 
the alarm deadband. 

HI_HI 
Priority

analog Determines the value (between 1 and 15) for the alarm priority
for the HI_HI alarm, where 15 represents the highest priority. 

HI Enabled analog Determines whether to enable HI alarms for a tag. 

HI Limit analog Determines the value, in engineering units, that invokes a HI 
alarm condition. The tag alarm state remains HI until the tag 
value goes below the HI alarm limit minus the alarm deadband

HI Priority analog Determines the value (between 1 and 15) for the alarm priority
for the HI alarm, where 15 represents the highest priority. 

LO Enabled analog Determines whether to enable LO alarms for the tag. 
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LO Limit analog Determines the value, in engineering units, that invokes a LO 
alarm condition. The tag alarm state remains LO until the tag 
value goes above the LO alarm limit plus the alarm deadband.

LO Priority analog Determines the value (between 1 and 15) for the alarm priority
for the LO alarm, where 15 represents the highest priority. 

LO_LO 
Enabled

analog Determines whether to enable LO_LO alarms for a tag. 

LO_LO Limit analog Determines the value, in engineering units, that invokes 
a LO_LO alarm condition. The tag alarm state remains 
LO_LO until the tag value goes above the LO_LO alarm 
plus the alarm deadband. 

LO_LO 
Priority

analog Determines the value (between 1 and 15) for the alarm priority
for the LO alarm, where 15 represents the highest priority. 

Discrete 
Enabled

discrete, 
bit array

Determines whether to enable tag value alarms for discrete an
bit array tags.

Alarm on discrete, 
bit array

Determines whether a discrete tag should be alarm on ON (hig
or OFF (low). Determines whether a bit array goes into alarm i
all of its bits are in alarm or if any of its bits are in alarm. This 
field is used only if both Alarms Enabled and Discrete Enabled
fields are set to TRUE.

Discrete 
Priority

discrete, 
bit array

Determines the value (between 1 and 15) for the alarm priority
for the tag value alarm, where 15 represents the highest priorit

Alarm Invert 
Mask

bit array Determines which bits are inverted before calculating the 
alarm state. Bits in the mask that are 1 are inverted; thus cause 
an alarm when low (0). Bits that are 0 are not inverted; thus, 
cause an alarm when high (1). The default mask is 0, indicatin
none of the bits are inverted. In bit-wise logic terminology, the 
Engine performs an XOR with the Invert Mask to produce the 
alarm state. The Alarm Invert Mask is applied to the scaled valu
after any relevant scaling masks are applied. 

Table 3-7.  Alarms Configuration Attributes  (Continued)

Attribute
Applies to 
Data Types  Description
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How Do You Configure Alarms for a Tag?
While editing a tag, click the Enable Alarms checkbox. Alarms are 
generated depending on the value or state of a tag. The alarms based
value vary with the tag data type. But for any tag, if the status is bad, a
Bad Status alarm is generated. By default, Bad Status Alarm is enable
and has the highest priority (15). You can change this selection from t
Alarms tab of the Tag Configuration Editor, shown in Figure 3-11.

Alarm Select 
Mask

bit array Determines which bits are used for the bit array alarm 
calculation. Bits in the mask that are 1 are used in the alarm 
calculation; bits that are 0 do not cause an alarm, regardless of 
their value. In bit-wise logic terminology, the Engine performs an
AND with the Select Mask to produce the alarm state. The Alarm
Select Mask is applied to the scaled value after any relevant 
scaling masks are applied. 

Alarm 
Message

discrete, 
bit array

Determines the string used to provide additional information 
about the meaning of an alarm condition. 

Tag Last 
Modified

all Indicates when the last edit to a tag occurred. 

Table 3-7.  Alarms Configuration Attributes  (Continued)

Attribute
Applies to 
Data Types  Description
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Analog Tags

Analog tags have four alarm levels: HI_HI, HI, LO, and LO_LO. By 
providing separate alarm levels, you can provide more information abo
the nature of the alarm condition.

Figure 3-11.  Alarms for Analog Tag Configuration

Alarms are calculated after scaling is performed. Alarm levels are 
expressed in engineering units.
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Discrete Tags

Discrete tags have one alarm state—either the tag is in alarm or it is n
You can determine whether a tag is in alarm when it is ON (High) or 
OFF (Low). Figure 3-12 shows the Alarms tab of the Discrete Tag 
Configuration dialog box.

 

Figure 3-12.  Alarms for Discrete Tag Configuration
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Bit Array Tags

You can enable one of two types of alarms for bit array tags. Alarm on
Any indicates the overall tag is in alarm if any of the bits are in alarm sta
Alarm on All means the overall tag is in alarm only if all of the bits are 
alarm state. You can use the Invert Mask to determine the bits that sh
use alarm on low (OFF) rather than the default alarm on high (ON). 
You can use the Select (AND) Mask to determine the bits that should 
be considered for the alarm. If you have bits in the Select Mask that a
zero (OFF), these bits are not used in calculation of the tag alarm stat
Figure 3-13 shows the Alarms tab of the Bit Array Tag Configuration 
dialog box.

Figure 3-13.  Alarms for Bit Array Tag Configuration

String Tags

String tags have no alarm states based on tag value. They only suppo
Bad Status alarms.

What Is Alarm Deadband on Analog Tags?
Alarm Deadband is a method commonly used to avoid repetitive alarm
messages because of a tag value that hovers near the alarm limit. Ala
Deadband defines how much a tag value must change from the alarm
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limit before it is considered normal. For example, if a tag that represen
temperature value hovers near an alarm limit of 40 degrees Celsius, th
might go in and out of alarm many times in a relatively short period of tim
Table 3-8 shows examples of events with Alarm Deadband set to 0.0%

 

This type of situation clogs event files with redundant information and 
can cause operators some frustration in having to acknowledge alarm
constantly when the tag has not changed significantly. You can use th
Alarm Deadband to alleviate this problem. 

For the tag to go into alarm, it must go above the exact Alarm Value (in
above example, 40). However, to be considered normal again, it must l
the Alarm Value by an amount greater than the Alarm Deadband. For 
example, if the range is 0 to 100 degrees Celsius, an Alarm Deadband
1.0% (one degree Celsius) eliminates unnecessary events. Table 3-9 s
examples of events with Alarm Deadband set to 1.0%. 

Table 3-8.  Events with Alarm Deadband = 0.0%

Time Value Event Alarm Type

9:15:05 40.1 Yes  HI 

9:15:10 39.9 Yes  Normal

9:15:15 40.1 Yes  HI 

9:15:20 38.5 Yes  Normal

Table 3-9.  Events with Alarm Deadband = 1.0%

Time Value Event Alarm Type

9:15:05 40.1 Yes  HI 

9:15:10 39.9 No  HI

9:15:15 40.1 No  HI

9:15:20 38.5 Yes Normal
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How Do You Keep an Alarm Unacknowledged 
after the Alarm Returns to Normal?
While editing a tag, select the Alarm Acknowledgement Mode ring and 
choose either Auto Ack on Normal or User Must Ack.

Auto Ack on Normal

With this option enabled, when a tag returns to normal state, the alarm
is automatically acknowledged. A message is logged to the event file 
event logging is turned on for the tag. By default, Auto Ack On Normal 
is enabled.

User Must Ack

With this option enabled, an alarm remains unacknowledged until the 
operator acknowledges the alarm.

How Do You Configure Other Engine Parameters?

There are other Engine parameters you can configure within 
the Tag Configuration Editor. You can define your Historical 
Logging Configuration and Event Configuration by selecting 
Configure»Historical… or Events… through the BridgeVIEW 
Tag Configuration Editor dialog box, shown in Figure 3-1. 

How Do You Turn on Historical and Event Logging at Startup?
To turn on historical and event logging at startup, select 
Configure»Historical… or Events… from the Tag Configuration Editor. 
Checkboxes in each dialog box turn on historical and event logging at
system startup. For more information, see Chapter 4, Alarms and Events, 
and Chapter 5, Historical Data Logging and Extraction.

How Do You Set the File Paths for Historical and Events Files?
From the main panel of the Tag Configuration Editor, select 
Configure»Historical… or Events…. The dialog box allows you to 
set the path to the directories containing historical or events files.
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How Do You Configure Shifts?
Shifts are valuable in configuring event logging. Shift start and stop tim
determine how event files are segmented, and end of shift reports can
these configuration files to determine process and line statistics. From
main panel of the Tag Configuration Editor, select Configure»Events…. 
The panel has a shift display with which you can edit the configuration

How Do You Configure Engine Parameters?
The BridgeVIEW Engine has several default settings for Engine 
parameters. However, you can override these defaults within the Buffe
Configuration dialog box by selecting Configure»Engine… from the Tag 
Configuration Editor. 

The BridgeVIEW Engine allocates certain amounts of memory for vario
queues. You can configure some of the parameters used by the Engin
Tags VIs to allocate memory for the Engine buffers yourself, but it is 
recommended you use the default values. The parameters you can 
configure are listed in Table 3-10.

Table 3-10.  Configurable Memory Allocation Parameters

Parameter Description Default Value

System Events 
display (lines

Determines the maximum number of lines of text to be 
displayed in the System Errors and Events display of the 
Engine Manager.

20 

Error Message 
repeat rate 
(seconds)

Determines the time, in seconds, that recurring error 
messages should be repeated to the user. For example, 
an undefined tag message error repeats only after this 
value is exceeded.

600 secs 
(10 minutes)

Event History 
Buffer size 
(elements) 

Determines the length, in elements of the queue that 
handles event information sent from the Engine to 
.evt files.

2000

Historical Log 
Queue (elements)

Determines the length, in elements, of the queue that 
handles data sent from the engine to the Citadel 
historical database.

2000

Server Input Queue 
size (elements) 

Determines the length, in elements, of the queue that 
handles data sent from the device servers to the Engine.

2000
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Note Although you can configure these parameters, it is highly recommended you 
maintain the default values.

How Do You Launch Server Configuration 
Utilities from the Tag Configuration Editor?

When you register a server in your system, BridgeVIEW registers 
the location of its configuration utility, if it exists. You can access 
the server configuration utilities from the Servers menu of the Tag 
Configuration Editor.

Note When you update the server registry while the Tag Configuration Editor is 
running, select Servers»Refresh to prompt the Tag Configuration Editor to 
read the updated information.

Server Input Queue 
binary size (bytes) 

Determines the length, in bytes, of the queue that 
handles binary data (string tags) sent from the device 
servers to the Engine.

2000

Server Output 
Queue size 
(elements) 

Determines the length, in elements, of the queue that 
handles data sent from the Engine to the device servers.

2000

Server Output 
Queue binary size 
(bytes) 

Determines the length, in bytes, of the queue that 
handles binary data (string tags) sent from the Engine to 
the device servers.

2000

Server Shutdown 
timeout (seconds) 

Determines the time, in seconds, the Engine waits for all 
active device servers to shutdown before asking the user 
if the servers are to be forcefully terminated.

30

Table 3-10.  Configurable Memory Allocation Parameters (Continued)

Parameter Description Default Value
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Alarms and Events

This chapter introduces the basic concepts of alarms and events, and
explains how to view, acknowledge, and configure them within the 
BridgeVIEW system. 

What are Alarms and Events?

An alarm is an abnormal process condition pertaining to a tag. 
In BridgeVIEW, alarms are generated based on changes in a tag valu
or status.

An event is something that happens within the BridgeVIEW system. 
Events can be divided into two groups: those that pertain to individual t
and those that pertain to the overall BridgeVIEW system. An example 
tag event is a change of alarm state for a tag. Examples of system eve
include a user logging on, the Engine starting up, or historical logging 
being turned on. For more information about system events, see Chap
BridgeVIEW Environment.

Alarm States
For analog tags, an alarm state can be of type HI_HI, HI, LO, or LO_L
For all data types (analog, discrete, bit array, and string), if the server 
returns a bad status, and you have enabled alarming on bad status, th
goes into Bad Status alarm. All data types except string also support al
based on tag value. If an analog tag exceeds a preconfigured alarm li
one of these alarms can occur. Discrete and bit array tags are either n
alarm or in alarm.

Alarm Limit
An alarm limit is the numeric value an analog tag must exceed to go in
an alarm state.
me System Guide
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Alarm Priority
An alarm priority indicates the severity of an alarm. Priorities range fro
1 (lowest) to 15 (highest). You can filter the alarms displayed in your H
by alarm priority. 

How Do You Configure Logging 
and Printing of Alarms and Events?

You can configure logging and printing options for Alarms and Events
through the Event Configuration dialog box, shown in Figure 4-1. This
configures the format of alarms and events written to .evt  files or printed. 
You can reach this dialog box by choosing Project»Tag»Configuration, 
and then Configure»Events from the Tag Configuration Editor. 

Figure 4-1.  Event Configuration Dialog Box
BridgeVIEW Run-Time System Guide 4-2 © National Instruments Corporation
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Table 4-1 provides a description of the general event configuration 
selections.

There are various format options for logging and printing. The print 
selections are a set of several parameters that determine the format o
the data to be printed. Similarly, the log selections are a set of several
parameters that determine the format of the data to be logged in an ev
file. These parameters are described in the following table. 

Table 4-1.  Tag Configuration Editor Event Configuration Selections

Selection Description

Event Directory Determines the path to the directory where the event files are stored on dis

Store absolute 
path

Determines whether the absolute path is stored.

Start event 
logging on 
system start-up

Determines whether the BridgeVIEW Engine automatically begins logging
events when the Engine launches.

Days to keep 
event files

Determines how many days worth of event files are kept on disk. Anything
older than the number of days specified here is deleted automatically. 

Log Delimiter Determines the separator between parameters on a line. By default, it is the
character. This makes event files easy to import into a spreadsheet progra
Spreadsheet programs can handle other delimiters as well. 

Shift Display
(00:00  – 23:59 )

An array of numerics ranging between 00:00  and 23:59  hours to determine 
the length of the shift that events are logged in a file. At the end of the shif
a new event file is generated and written to. 

Start printing on 
system start-up

Determines whether the BridgeVIEW Engine automatically begins printing
events when the Engine launches.

Printer Determines the port to which your printer is connected.

Print Delimiter Determines the separator between different parameters on a line. By defa
it is a comma. 

Min Priority Determines the minimum priority an event must have before it is logged. 
Events with priorities below this configured number are not logged. The 
minimum value is 1.

Max Priority Determines the maximum priority an event can have to be logged. Events 
with priorities above this configured number are not logged. The maximum
value is 15.
© National Instruments Corporation 4-3 BridgeVIEW Run-Time System Guide
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Table 4-2.  Event Configuration, Log, and Print Format Selections

Selection Description

Date Determines whether the date is logged or printed.

Date Format A menu ring that allows you to pick a format for the date to be printed. Th
selection is valid only if Date is selected. The menu items are: MM/DD/YYYY 
and DD/MM/YYYY.

Time Determines whether the time is logged or printed.

Time Format Determines the format for the time logged or printed. This selection is vali
only if Time is selected. The menu items are: AM/PM and 24 HOUR.

Tag Name Determines whether the tag name is logged or printed.

Tag Name Field 
Length

Determines the maximum number of characters for the tag name. 
This selection is valid only if Tag Name is checked.

Event Type Determines whether the event name is logged or printed.

Group Name Determines whether the group name is logged or printed.

Group Name Field 
Length

Determines the maximum number of characters for the group name. 
This selection is valid only if Group Name is checked. 

Alarm Value Determines whether the alarm value is logged or printed.

Alarm State Determines whether the alarm state is logged or printed.

Alarm Ack State Determines whether the alarm acknowledge state is logged or printed.

Alarm Priority Determines whether the alarm priority is logged or printed.

Alarm Limit Determines whether the alarm limit is logged or printed.

Operator Name Determines whether the name of the current operator is logged or printed

Operator Name 
Field Length

Determines the maximum number of characters for the operator name. 
This selection is valid only if Operator Name is checked. 

Alarm Message Determines whether the alarm message is logged or printed.

Alarm Message 
Field Length

Determines the maximum number of characters for the alarm message. 
This selection is valid only if Alarm Message is checked.
BridgeVIEW Run-Time System Guide 4-4 © National Instruments Corporation
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How Do You Log Alarms and Events?
Events are logged in ASCII files named in the format YYMMDDHHMM.evt 
using the timestamp of the first point to be logged. YY is the year, MM is the 
month, DD is the day, HH is the hour, MM is the minute and .evt  is the 
extension for all event log files.

There are three steps you must complete to log alarms and events:

1. Configure your tags to have Log/Print Events enabled. You config
it on a per tag basis. To select event logging for a single tag, go to
panel for configuring the tag. 

2. Configure a path to a directory for the event (.evt ) files. To choose the 
path, select Configure»Events… in the Tag Configuration Editor. 

3. Turn on event logging for the BridgeVIEW Engine, according to on
of the techniques outlined below. 

There are two techniques for turning event data logging on or off:

• You can configure event logging in the Tag Configuration Editor. 
To turn on event logging, select Configure»Events…. Configure the 
path and set Start logging on system start-up to be TRUE. 

• The Engine Manager also has a button to turn event logging on or
If you have Supervise or higher-level privileges, you can access th
button.

Table 4-2 provides a description of the event logging configuration 
selections.

How Do You Print Alarms and Events?
In BridgeVIEW, events are printed to a standard line printer through a
parallel port. There are three steps you must complete to print alarms
events:

1. Configure your tags to have Log/Print Events enabled. You config
it on a per tag basis. To select event printing for a single tag, go to
panel for configuring the tag. 

2. Configure a printer for event printing. To choose the printer, select
Configure»Events… in the Tag Configuration Editor. 
© National Instruments Corporation 4-5 BridgeVIEW Run-Time System Guide



Chapter 4 Alarms and Events

e 

r. 

 or 
s 

s.

ault 
kes 
3. Turn on event printing for the BridgeVIEW Engine, according to on
of the following  two  techniques:

• You can configure event printing in the Tag Configuration Edito
To turn on printing, select Configure»Events…. Configure the 
printer and set Start printing on system start-up to be TRUE. 

• The Engine Manager also has a button to turn event printing on
off. Those with Supervisor or higher-level privileges can acces
this button.

Table 4-2 provides a description of the printing configuration selection

How Do You View Alarms and Events?
Event files are ASCII files, and can be read with any text editor. The def
delimiter between the various parameters is a tab character, which ma
viewing the file in a spreadsheet program, such as Excel, convenient.
BridgeVIEW Run-Time System Guide 4-6 © National Instruments Corporation
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Historical Data Logging 
and Extraction

This chapter explains the concept of a trend, how to log and extract 
historical data, and how to use the Historical Trend Viewer (HTV), a util
that displays historical data that has been logged to disk with BridgeVIE

What Is a Trend?

A trend is a display of tag values against time. BridgeVIEW displays ta
values with two types of trends: real-time trends and historical trends.

Real-Time Trend
A real-time trend is a display of tag values as they are collected in real t
over a relatively short period of time.

Historical Trend
A historical trend is a display of tag values that have been logged to d
This is usually over a relatively long period of time. You can view 
historical data by launching the HTV utility. 

What Is Citadel?

Citadel is a high performance historical database. With Citadel, 
BridgeVIEW can log tags while continually servicing data queries.
BridgeVIEW also includes the Citadel ODBC driver that has special 
commands to perform data transforms, making it easy for you to retrie
manipulate, and analyze historical data automatically from outside the
BridgeVIEW environment. For more information, see Appendix A, 
Citadel and Open Database Connectivity. 
me System Guide
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How Do You Log Historical Data?

There are three steps you must complete to log historical data:

1. Configure your tags to have historical logging enabled. You configu
it on a per tag basis. To select historical logging for a single tag, go
the panel for configuring the tag. 

2. Configure a path for the historical database. To choose the path, s
Configure»Historical… in the Tag Configuration Editor. 

3. Turn on historical logging for the BridgeVIEW Engine, according t
one of the three techniques outlined below. 

There are two techniques for turning historical data logging on or off: 

• You can configure historical logging in the Tag Configuration Edito
To turn on logging, use the pull-down menu for 
Configure»Historical…. Configure the path and set Start logging on 
system start-up to be TRUE. 

• The Engine Manager also has a button to turn historical data logg
on or off. If you have Supervise or higher-level privileges, you can
access this button.

When you log historical data for your application, there is a coupling 
between your configuration (.scf ) file and the Citadel Historical 
Database. When you decide to archive these, take the .scf  file along with 
your historical files to the new location. Although you can retrieve 
historical data without the .scf  file, you will not have the tag configuration
information, such as engineering range and unit, unless you archive th
.scf  file as well. 

Preferably, maintain the relative path between the .scf  file and the 
historical files in this new location. For example, if your .scf  file is 
in C:\ARCHIVE , keep your historical database in C:\ARCHIVE\DATA . If 
you save a new .scf  file and have not specified a historical data director
you are prompted to specify the path and the directory is created for y

How Do You Configure Historical Logging?
You can reach the Historical Logging Configuration dialog box by 
selecting Configure»Historical… from the Tag Configuration Editor. 
Figure 5-1 shows the Historical Logging Configuration dialog box 
and Table 5-1 lists parameters you can configure for historical logging
BridgeVIEW Run-Time System Guide 5-2 © National Instruments Corporation
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Figure 5-1.  Historical Logging Configuration Dialog Box

Table 5-1.  Parameters You Can Configure for Historical Logging

Selection Description

Citadel Data Directory Path that determines the directory where historical data files are stor
on disk.

Store absolute path Determines whether the absolute path is stored.

Start logging on system 
start-up

Determines whether the BridgeVIEW Engine automatically begins 
logging historical data when the Engine launches.

Days to keep historical 
files

Determines how many days worth of historical log files to keep on dis
Anything older than the number of days configured here is deleted 
automatically.

Maximum time 
between log records

Time, in seconds, that determines the logging rate for tags that vary 
slowly.
© National Instruments Corporation 5-3 BridgeVIEW Run-Time System Guide
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How Do You Extract and View Data 
from Historical Log Files?

In addition to any historical trending tools included with the application
software, you can use the Historical Trend Viewer to view historical da
that has been logged to disk. 

Historical Trend Viewer (HTV)
The HTV is a stand-alone utility that enables you to look at historical d
in your system. The HTV limits you to viewing no more than eight tags
a time. 

Your application software might offer an alternative way to view historic
data. For more information, consult the documentation for your applicat
or the system developer.

To start the HTV, select Project»Historical Trend Viewer…. The HTV is 
shown in the following illustration. 

Figure 5-2.  Historical Trend Viewer
BridgeVIEW Run-Time System Guide 5-4 © National Instruments Corporation
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How Do You Select the Tags to Display?
Select File»Select Tags…, and the Select Tags dialog box appears, as 
shown in Figure 5-3. With this dialog box, you can select either a .scf  
file or a directory of Citadel files. The default is to choose a .scf  file. 
The .scf  file you choose must point to a valid directory of Citadel files
If the BridgeVIEW Engine is running, the .scf  file being used by the 
BridgeVIEW Engine is displayed. 

 

Figure 5-3.  Select Tags Dialog Box

Note You can look at data from only one Citadel database at a time.

Select the tags from the Available Tags list that you want to display. 
The HTV displays the tags in the order that they are listed in the Tags
Display list.

Note You can view configuration information about a tag by selecting it in the Availabl
Tags list, and clicking on the Tag Information  button.
© National Instruments Corporation 5-5 BridgeVIEW Run-Time System Guide
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How Do You Change the Time Axis?
You can change the time axis for a trend within the HTV manually, or 
using Panning buttons. 

Panning Buttons

The Panning buttons allow you to move backward and forward through t
historical data in the trend. The buttons do not affect the timespan of t
trend. For example, if the trend displays data from 9:45 to 9:55 on the s
day, the timespan is ten minutes. Table 5-2 describes the Panning button 
functions.

Manual Changes

You can also select the text at either end of the time axis and change 
data. You must enter the date in the correct format. If you make an er
the input is ignored.

You can select and enter the time and date on the time (X) axis of the 
historical trend on the HTV directly. However, the HTV responds 
immediately to any changes you make. If you want to make manual edi
both the start and stop time on the time axis, you can select the 
Viewer»Time & Date option. When you select this option, a dialog box
appears, in which you can enter the start and stop time of the data disp
in the trend.

Table 5-2.  Panning Button Functions

Button Name Description

|< Retrieve oldest data Displays the first available page of data.

<< Back to closest point Centers the display around the closest point to the left of th
timespan. If there is no data in the previous time span, skip
to the previous end of data.

< Back one-half page Moves the display back by half of the current timespan.

> Forward one-half page Moves the display forward by half of the current timespan.

>> Forward to closest point Centers the display around the closest point to the right of th
timespan. If there is no data in the next time span, it skips t
the next start of data.

>| Most recent data Displays the most recent available page of data.
BridgeVIEW Run-Time System Guide 5-6 © National Instruments Corporation
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How Do You Change the Timespan 
of Data Displayed?
The timespan indicator displays the amount of relative time between t
start and end points of the time axis. To change the amount of time betw
these points, you either can manually reenter data in the start or end p
on the time axis, or pull down the ring for the timespan indicator.

By default, the timespan ring contains the values 1:00, 5:00, 10:00, an
30:00. Select Enter New… in the timespan ring if you would like to enter
a different amount of data to display.

How Do You View the Value of a Tag 
at a Specific Point in Time?
The Data Display table on the HTV, shown in Figure 5-2, shows the ta
displayed in the trend, the tag description, and, for analog tags, the 
engineering units associated with the tag. The two rightmost columns s
the values of the tags at the two cursor locations in the trend. For disc
tags, the values in these columns are either On or Off . To move the cursors, 
grab their pointers at the bottom of the trend display. 

How Do You Change the Y Axis?
The HTV displays two Y axes at any time. Each Y axis displays the co
of the tag associated with it. All discrete tags show their ranges as goi
from On to Off . Click on the Y axis to make it rotate through the tags 
displayed in the trend.

To change the range in the Y axis for analog and bit array tags, select
text at the top or bottom of the scale and type in the desired value. Wh
you enter the value, that trend scale changes and the trend display upd
Discrete tags are displayed without Y axis scales, and ranges are show
On or Off .
© National Instruments Corporation 5-7 BridgeVIEW Run-Time System Guide
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How Do You Change the Plot Colors 
and Style in the Trend?
Click on the Trend Legend. The pop-up window contains several option
with which you can change the plot colors and styles used in the trend

How Do You Zoom In on the Trend?
The HTV Trend  palette contains a Zoom tool that allows you to zoom 
on points of interest. The Zoom tool has five modes with which you ca
zoom in on the trend: 

• Zoom by rectangle

• Zoom time scale

• Zoom Y scale

• Zoom in about one point

• Zoom out about one point

Undo Zoom resets the graph to its previous setting.

How Do You Export Data to a Spreadsheet?
From the HTV, select File»Export…. The HTV exports the information 
currently displayed in the trend to a tab-delimited file. A dialog box 
prompts you for the name and location of the file to create. 

The HTV resamples data in periodic intervals so that all tags have the s
number of data points. The frequency defaults to a value according to
frequency of data in the historical files. If you want to override this valu
enter the frequency you want in the dialog box.

How Do You Get Online Help for the HTV?
From the HTV, pull down the Help menu and select Show Help. A floating 
window is displayed that shows help information for all of the objects o
the HTV panel.
BridgeVIEW Run-Time System Guide 5-8 © National Instruments Corporation
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How Do You Set Tag, Time, and Color Preferences?
Set the preference for the HTV to remember settings for display time a
color on exit by selecting Viewer»Preferences…. When you exit the HTV, 
the state of the viewer is recorded.

 

Select the Remember settings on exit checkbox if you want to update your
settings each time you exit the HTV. 

How Do You View New Data Automatically After It 
Has Been Logged to Citadel?
You can use Live Mode to watch incoming data after it has been logge
When the Engine is turned on with historical logging enabled, the Live 
button appears to the right of the panning buttons. When you click the
Live button, the trend automatically updates periodically. Select 
Viewer»Preferences… in the HTV Preferences dialog box to set how 
often the trend will display the new data. The default is 10 seconds. If 
Always scroll with new data is checked, the display updates whenever
new data is logged. 

While Live Mode is turned on, the values for each tag are extrapolated
the last time the trend was updated. These extrapolated values are ma
with an asterisk in the Data Display. When a cursor or slider is placed 
before the extrapolation begins for a tag, the asterisk will not be prese
Turning off Live Mode also turns off extrapolation.
© National Instruments Corporation 5-9 BridgeVIEW Run-Time System Guide
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BridgeVIEW Security

This chapter explains the BridgeVIEW security system. BridgeVIEW 
environment security does not take effect until you configure it. 
Configuration consists of adding users and assigning them access lev
privileges, and passwords.

Environment Security

Access to most BridgeVIEW utilities and the BridgeVIEW Engine can 
configured on a per-user basis. For example, not all users should be ab
configure the tags in the system or create and edit user accounts. The
privileges that can be assigned to a user are defined in Table 6-1.

Table 6-1.  Assignable BridgeVIEW Privileges

Type Privilege Description

Environment 
Privileges

Use Historical Trend Viewer User can launch, configure, and use the 
Historical Trend Viewer utility.

Use Tag Monitor User can launch, configure, and use the Tag
Monitor utility.

Use Tag Browser User can use the Tag Browser utility.

Use Server Browser User can use the Server Browser utility.

Disable <Alt> Key If enabled, the <Alt> key on the keyboard is 
disabled in BridgeVIEW.

Configure Startup VIs User can assign VIs to launch when 
BridgeVIEW is started.
me System Guide
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A user’s BridgeVIEW Environment privileges are completely independe
of the user’s access level, and do not directly affect access to objects i
operator interfaces that you develop for your application. 

Project 
Privileges

Configure Log File Locations User can use the Tag Configuration Editor to
edit the historical and event logging 
configuration of a tag configuration, but can 
not create, delete, or edit tags.

Create/Edit Tags User can create, delete, and edit tags in the
Tag Configuration Editor.

Use Interactive 
Server Tester

User can launch the Interactive Server 
Tester; this privilege can be configured only 
if the VI Server Developer Toolkit is 
installed.

Engine 
Privileges

Start/Stop Engine User can start and stop the Engine via the 
Engine Manager.

Start/Stop Historical Logging User can start and stop Historical Logging 
via the Engine Manager.

Start/Stop Event Logging User can start and stop Event Logging via 
the Engine Manager.

Start/Stop Printing User can start and stop Event Printing via the
Engine Manager.

Security 
Privileges

Change Password User can change his or her own password.

Create/Edit Access Levels Using the Access Levels dialog box, the user
can add, remove, and edit access levels lowe
than his or her own access level.

Create/Edit User Accounts User can create and edit user accounts whic
have an access level lower than his or her 
own access level.

Configure User Privileges User can change the privileges assigned to 
other users who have an access level lower
than his or her own. This privilege requires 
that the user also have the Create/Edit User
Accounts privilege, described above.

Table 6-1.  Assignable BridgeVIEW Privileges (Continued)

Type Privilege Description
BridgeVIEW Run-Time System Guide 6-2 © National Instruments Corporation
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How Do You Log In and Out?
To log in, choose Project»Security»Login. Type in your account name 
and password. If you do not know your login name, or have forgotten y
password, contact your BridgeVIEW administrator.

To log out, choose Project»Security»Logout.

How Do You Find Your Access Level?
After you have logged in, you can find your access level by choosing 
Project»Security»Access Levels…. When you make this selection, the 
Access Levels dialog box appears, as shown in Figure 6-1. 

Figure 6-1.  Access Levels Dialog Box

You also can view your privileges by clicking the Privileges… button. For 
more information about privileges, refer to Table 6-1 and to the followin
section.

How Do You Find Your Environment Privileges?
After you have logged in, you can find your environment privileges by 
choosing Project»Security»Privileges…. When you make this selection,
the Privileges dialog box appears, as shown in Figure 6-2. 
© National Instruments Corporation 6-3 BridgeVIEW Run-Time System Guide



Chapter 6 BridgeVIEW Security

 

 full 
curity 
ccess 

ess 

ser 
 the 
Figure 6-2.  Privileges Dialog Box

For more information about BridgeVIEW user privileges, refer to 
Table 6-1.

How Do You Change Your Password?
You must be logged in to change your password. Choose 
Project»Security»Change Password. 

Type in your old password, then your new password. Type in your new
password again to verify it.

How Do You Restrict Access to the BridgeVIEW Environment?
When you install BridgeVIEW, no user accounts exist, so all users have
access to the system. You must create user accounts for the normal se
features to take effect. When you create user accounts, you assign an a
level to each account. 

When a user logs in, BridgeVIEW obtains the user’s privileges and acc
level.  

How Do You Create and Modify User Accounts?
To create and modify user accounts, you must have the Create/Edit U
Accounts privilege. To change a user’s privileges, you also must have
Configure User Privileges privilege. To edit the list of user accounts, 
choose Project»Security»Edit User Accounts…, and the Edit User 
Accounts dialog box appears, as shown in Figure 6-3.
BridgeVIEW Run-Time System Guide 6-4 © National Instruments Corporation
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Figure 6-3.  Edit User Accounts Dialog Box

Click the Add New Users >> button to create a new user account. Type 
a name, select an access level, and provide a password for the accou
modify the privileges for the account, click the Privileges… button. Click 
the Add button to complete the addition of the new user account.

Figure 6-4.  Add a User Account
© National Instruments Corporation 6-5 BridgeVIEW Run-Time System Guide
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After you have defined user accounts, you also can use this utility to cre
remove, or modify accounts. To modify several user accounts at once
example, change the access level of several accounts to be the same v
hold down the <Shift> key when selecting users from the list.

Note Once you have defined user accounts, you must have at least one “super use
account (Access Level 255, privileges to Create/Edit user Accounts and Config
User Privileges), unless you remove all user accounts.

Note You only can add, remove, or modify accounts if you have the Create/Edit Use
Accounts privilege. Also, unless you are a “super user,” you can only create, 
remove, or edit user accounts that have an access level lower than your own. If 
are not authorized to configure user privileges, default privileges are assigned
new user accounts.

How Do You Modify the List of Available User Access Levels?
To edit the list of access levels, select Project»Security»Access Levels. 
You must have Administration privileges to edit the list of Access Leve
Click the Edit…  button next to the list of access levels. The Edit Access 
Levels dialog box appears, in which you can add, remove, and modify
access levels. You also can edit access levels within the Edit User 
Accounts dialog box by pressing the Edit Access Levels button, or 
choosing New… from the Access Level ring when creating or modifying
a user account. In addition to the two permanent access levels 0 and 
you can assign up to 254 access levels for use in your operator interfa
panels. If you remove an access level, users who have been assigned
access level are demoted to the next lower access level.

Note You can rename, but not remove, access levels 0 and 255.

How Do You Export a List of Users to a File?
You can export a list of users to binary or text files. Text files contain on
the user name, access level, and privileges. To export all user accoun
information, including passwords, you must export to a binary file.

To export the user list to a text file, click the Export User List… button 
or select File»Export»Text File…. You can export to tab-delimited or 
comma-delimited text files. For a description of how privileges are 
exported, see the How Do You Import a List of Users from a File? 
section later in this chapter.

To export a list of users to a binary file, choose File»Export»Binary 
File…. Exporting a list of users to a binary file is useful for distributing 
BridgeVIEW Run-Time System Guide 6-6 © National Instruments Corporation
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your list of users to other computers. The advantage of using a binary
file is that all user account information, including passwords, is include
in the file.

How Do You Export Users to Another Computer on the Network?
You can put BridgeVIEW user accounts on other computers either by 
exporting the user list to a text or binary file on one machine and import
on another, or by choosing File»Export»Network BridgeVIEW .

If you choose the File»Export»Network BridgeVIEW  option, a dialog 
box appears in which you can type in the name of the computer to exp
the accounts to, or you can browse the network. BridgeVIEW must be
installed on the other computer for the export to function correctly.

Note (Windows 95) To access the user account list on another computer over the netwo
you must have access to the Windows Registry on the remote machine. Remo
Registry access does not function unless the Remote Administration service is
installed and running on the Windows 95 machine attempting to access anothe
computer’s BridgeVIEW account list, or whose account list is to be accessed b
another computer. Consult your Windows 95 documentation to determine if 
Remote Administration is enabled, and how to install it if it is not. This service 
automatically available in Windows NT.

How Do You Import a List of Users from a File?
You can import users into your BridgeVIEW system from a tab-delimit
or comma-delimited text file, or from a binary file created by BridgeVIEW
To import a list of users from a text file, click the Import User List… 
button, or select File»Import»Text File… .

When importing from a text file, the first column should contain the use
name, the second column the access level, and the third column a list
privileges enabled for the user. The privileges enabled for a user are 
separated by semicolons. Table 6-2 provides a list of privileges, and th
abbreviation that must be used to enable the privilege for a user.
© National Instruments Corporation 6-7 BridgeVIEW Run-Time System Guide
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For example, a user named user , having access level 100 and privileges t
use the Tag Monitor, Tag Browser, and launch the engine would have 
following privileges string (in tab-delimited format):

user 100 Engine; TM; TB;

The default password for each user imported from a text file is the use
account name. To change this, click the Use Default Password check box 
and type in a new password. Note that this changes the password for 
imported accounts.

To import a list of users from a binary file, choose File»Import»Binary 
File… and select a file from the list that appears in the dialog box. For m
information about creating and exporting to a binary file, see the How Do 
You Export a List of Users to a File? section earlier in this chapter.

Table 6-2.  Abbreviations Used to Enable Privileges for a User

Privilege Abbreviation

Start/Stop Historical Logging HistLog

Start/Stop Event Logging EvtLog

Start/Stop Printing Print

Use Historical Trend Viewer HTV

Use Tag Monitor TM

Use Tag Browser TB

Use Server Browser SB

Disable <Alt> Key Alt

Configure Startup VIs ConfigStartup

Configure Log File Locations LogFileLoc

Create / Edit Tags EditTags

Use Interactive Server Tester 
(if installed)

IST

Create / Edit User Accounts EditUsers

Create / Edit Access Levels EditAccessLevels
BridgeVIEW Run-Time System Guide 6-8 © National Instruments Corporation
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How Do You Import Users from Another Computer on the Network?
You can import BridgeVIEW user accounts from other computers from
text or binary file or by choosing File»Import»Network BridgeVIEW .

If you choose File»Import»Network BridgeVIEW , a dialog box appears 
in which you can type in the name of the computer to import the accou
from, or you can browse the network.

Note (Windows 95) To access the user account list on another computer over the netwo
requires access to the Windows Registry of the remote machine. Remote Reg
access does not function unless the Remote Administration service is installed 
running on any Windows 95 machine that attempts to access another compute
BridgeVIEW account list, or whose account list is to be accessed by another 
computer. Consult your Windows 95 documentation to determine if Remote 
Administration is enabled, and how to install it if it is not. This service is 
automatically available in Windows NT.
© National Instruments Corporation 6-9 BridgeVIEW Run-Time System Guide
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Servers

This chapter explains how to use servers with BridgeVIEW. BridgeVIE
supports several types of servers including OPC Servers, DDE Serve
and National Instruments Standard IA Device Servers.

OPC Servers are written to the OPC Foundation OPC Data Access 
specification and are provided by many companies. A DDE Server is 
any server that supports the DDE Server interface. IA Device Servers 
are a type of server developed by National Instruments. There are two
implementations of IA Device Servers: VI-based and DLL-based. 
The DLL-based servers are also known as IAK Device Servers.

This chapter also describes how to install and configure the IA Device
Servers available from National Instruments and how to view the serve
configuration within BridgeVIEW.

BridgeVIEW includes the NI-DAQ Server, an IA Device Server that 
supports National Instruments data acquisition boards and SCXI, on 
the BridgeVIEW Development System CD. Additional device servers 
for other devices such as PLCs also are available for BridgeVIEW 
on the BridgeVIEW Device Servers CD. For more information about 
BridgeVIEW device servers, inquire about the Device Servers CD, 
available from National Instruments.

What Are BridgeVIEW Device Servers?

A BridgeVIEW device server is an application that communicates with 
and manages I/O devices such as PLCs, remote I/O (Input/Output) dev
remote BridgeVIEW Engines, and data acquisition plug-in cards. Devi
servers pass real-world tag values to the BridgeVIEW Engine in real ti
Each server monitors the device items and encapsulates all device- a
hardware-specific details, thereby establishing a device-independent I
layer for BridgeVIEW.

An item in BridgeVIEW is a channel or variable in a real-world device. 
For more information about how to connect a tag to a server and item,
see Chapter 3, Tag Configuration. 
me System Guide
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The device servers also handle and report communications and devic
errors to BridgeVIEW. There are different servers available for differen
device families and communication networks. 

Each device server is a stand-alone component that might include a 
configuration utility as well as the run-time application that communica
with the BridgeVIEW Engine. IA Device Servers are not built into the 
BridgeVIEW Engine itself. These servers are written to a National 
Instruments standard client/server Applications Programming Interface
(API) for communicating with the BridgeVIEW Engine and the Commo
Configuration Database.

When BridgeVIEW runs an application, it determines from the tag 
configuration (.scf ) file which servers are needed, and which items are
needed from those servers. BridgeVIEW launches each server it need
and notifies each one to monitor the specific items of interest. Typicall
servers monitor each input tag on a regular basis, passing the values 
the BridgeVIEW Engine when they change, and updating each output
when the BridgeVIEW HMI application writes that tag value. The upda
rates and deadband servers use for monitoring items can be configure
part of tag configuration. You define how a server monitors the items, h
often it polls the devices, and other server-specific and device-specific
parameters through each device server configuration utility.

How Do You Install and Configure a Device Server?

BridgeVIEW works with several device servers including the NI-DAQ 
OPC Server, the device servers available on the BridgeVIEW Device 
Servers CD, and the simulation servers installed with BridgeVIEW. 
In addition, you can use other servers available from companies other 
National Instruments.

To use a device server with BridgeVIEW, first you must install the devi
server and register it or run its configuration utility. More specific 
information on installing and registering National Instruments servers 
follows later in this section. This information is written to the Common 
Configuration Database, where BridgeVIEW obtains the server 
information. For some servers, you configure devices and items with t
server-specific Configuration Utility. Then, the Tag Configuration Edito
imports server, device, and item information so you can create tags. IA
device servers allow you to directly create and configure communicati
resources, devices, and items from the Tag Configuration Editor.
BridgeVIEW Run-Time System Guide 7-2 © National Instruments Corporation
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When you register a device server, its name appears in the list of serv
shown in the various Edit Tag screens of the Tag Configuration Editor.
Once you configure your server, you can create a BridgeVIEW 
Configuration using that server. Depending on the server, different 
information is written to the Common Configuration Database (CCDB)
when the server is registered.

The most simple servers register no more than their names and launc
paths. You can select items by adding in the item strings in the Edit Tag 
dialog box for each tag using that server. To select a device, you must c
an I/O Group and select or enter the device name in the I/O Group dia
box. Refer to your server documentation for the correct formats for the
device and item strings.

The IAK Servers allow you to create and configure communication 
resources, devices, and items directly in the Tag Configuration Editor. 
Communication resources and devices are configured in the I/O Grou
dialog box. Items are configured in the Connection tab of the Tag 
Configuration dialog box.

Other servers register the devices to which they are connected and ava
items for those devices by name. These servers also can register the 
type, directions, and engineering range and units of the various items,
applicable. When you select these servers in the Edit Tag screens of t
BridgeVIEW Tag Configuration Editor, you must first create an I/O grou
and select a device. Then you see a list of available devices, and a lis
items connected to that device in the Edit Tags screen. For a selected d
and item, the BridgeVIEW Tag Configuration Editor imports any availab
item engineering range and unit information and also checks that the 
directions or access rights for an item are compatible with the access r
you have selected for the tag. Check your server documentation to find
if it registers device and item names and item parameters with 
BridgeVIEW.

Installing and Configuring the NI-DAQ OPC Server
The NI-DAQ OPC Server is available as part of NI-DAQ 6.x, and is 
included on the BridgeVIEW Run-Time System CD. You can choose t
install the NI-DAQ OPC Server at the same time you install NI-DAQ, o
you can install the NI-DAQ OPC Server at a later time. Select the NI-DA
OPC Server when you are prompted to install servers.

After you install the NI-DAQ OPC Server, you must run the NI-DAQ 
Configuration Utility and the Channel Wizard to configure your DAQ 
system before you can use the NI-DAQ OPC Server with BridgeVIEW.
© National Instruments Corporation 7-3 BridgeVIEW Run-Time System Guide
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All Channels created with the NI-DAQ Channel Wizard appear as item
when the DAQ OPC Server is selected in BridgeVIEW.

Installing and Configuring Device Servers 
from the BridgeVIEW Device Servers CD

The BridgeVIEW Device Servers CD contains servers for several PLC
and remote I/O devices. These device servers are DLL-based servers 
the Device Server Toolkit interface to BridgeVIEW.

To install the BridgeVIEW Device Servers from the BridgeVIEW Devic
Servers CD, follow these steps.

1. Insert the CD in your CD-ROM drive.

If you are running BridgeVIEW on Windows 95 or NT 4.0,

select Run… from the Start menu.

2. Follow the instructions that appear on the screen.

The Installer prompts you to select one or more servers to install. It al
installs the Server Explorer, which all the device servers contained on
CD use for server configuration. After you run the installer, you must r
the Server Explorer to configure the device-specific parameters of you
industrial network before using the server with BridgeVIEW. The Serve
Explorer also registers your server so you can use it with BridgeVIEW
Each server on-line help file documents configuration instructions spec
to each server on the CD. See the on-line help files for your server for
more information.

How Do You Use OPC Servers with BridgeVIEW?

BridgeVIEW can communicate with any server implementing the OPC
Foundation OPC Server interface, a Microsoft COM-based standard. 
BridgeVIEW automatically finds all OPC Servers installed in your syste
and searches the network for OPC servers on other machines. Unlike
Device Servers, OPC Servers do not store information in the Common
Configuration Database, rather BridgeVIEW reads any available 
information about server capabilities and items from the server directly

OPC Servers are listed in the Server Name List when you configure 
a BridgeVIEW tag using the Tag Configuration Editor. To connect a 
BridgeVIEW tag to an OPC Server item, you select the server and ent
or choose the item name along with other parameters you might need
specify, such as the access path. You also create I/O Groups for the it
BridgeVIEW Run-Time System Guide 7-4 © National Instruments Corporation
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specifying update rate and deadband information for each group. Eac
BridgeVIEW I/O Group created in the Tag Configuration Editor is 
automatically mapped to an OPC Group in the OPC Server with the 
same attributes.

OPC Servers have an optional interface called the Server Browse Add
Space Interface. If a server supports this interface, BridgeVIEW can qu
it to find which items are available from the server and display them in 
item list when the server is selected in the Tag Configuration dialog bo
In this case, the Browse button in the Tag Configuration dialog box is 
enabled, and you can press this button to view the hierarchical 
organization of the server Item IDs.

You can also view the OPC Server Items and their attributes using 
the Server Browser utility. Launch the Server Browser by selecting 
Projects»Server Tools»Server Browser… or pressing the Server 
Browser… button on the Engine Manager display.

Figure 7-1.  Server Browser
© National Instruments Corporation 7-5 BridgeVIEW Run-Time System Guide
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When an OPC server is selected in the Servers list, you can press the View 
Server Information… button to bring up the View Server Information fo
OPC Servers dialog box, as shown in Figure 7-2.

Figure 7-2.  View Server Information Dialog Box

This dialog box displays general information about the OPC Server as 
from your local system registry. If the OPC server supports the Server
Browse Address Space interface, the View Server Information dialog b
also displays the items available from the server and their attributes. If
OPC Server does not support this interface, the No Items Found checkbox 
and the item table appear dimmed.

Using Remote OPC Servers
You can use the Server Browser to configure BridgeVIEW to access O
Servers on other machine on your network. Use this utility to select rem
OPC Servers and add them to the BridgeVIEW server list.
BridgeVIEW Run-Time System Guide 7-6 © National Instruments Corporation
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To view the OPC servers available on other machines on your network
press the Browse Network OPC Servers button on the Server Browser. 
This brings up the Browse OPC Servers on Network dialog box shown
below.

Figure 7-3.  Browse OPC Servers on Network Dialog Box

Use this dialog to view the OPC servers registered on other machines
your network. The Registered Remote OPC Servers list shows which 
remote servers have been added to the BridgeVIEW servers list. If you w
to use the server on another machine from your machine, use the netw
tree control to open the machine, and select one of the OPC servers s
on that machine and press the Add Server >> button. The information for 
the remote OPC server is now stored in your local machine registry, and
server will appear in your BridgeVIEW servers list with the server nam
format of ( machine name )programID . BridgeVIEW runs the server on
the remote machine when you configure a tag to use that server. 

To remove one or more remote OPC server from the BridgeVIEW serv
list, select the servers and press the Remove Server(s) button. The servers 
will no longer appear in your BridgeVIEW server list.
© National Instruments Corporation 7-7 BridgeVIEW Run-Time System Guide
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You can also use the Windows utility dcomcnfg.exe  to configure an OPC 
server to run on a remote machine rather than your local machine. In o
to use dcomcnfg.exe  to configure an OPC server on a remote machine
you must also have the server registered on your local machine.

To register an OPC server on your local machine, either install the ser
locally or run the server registration utility on your local machine. Then
launch dcomcnfg.exe  and complete the following steps.

1. Select the OPC server in the Applications list, under the Applications 
tab, and press the Properties button.

2. Click the Location tab in the Properties dialog box. De-select 
theRun application on this machine checkbox and check the 
Run application on the following computer: checkbox. Enter the 
name of the machine or use the Browse button to select the remote 
machine. Press OK  to close the Properties dialog box.

3. Select the Default Properties tab and make sure that the Enable 
Distributed COM on this computer checkbox is checked. Also, 
set the Default Authentication Level to Connect, and set the 
Default Impersonation Level to Identify .

4. Select the Default Security tab, and press the Edit Default…  button. 
Make sure that the machine on which you plan to launch the OPC
server is allowed to access your machine. This is necessary for th
machine to call back the BridgeVIEW on your machine when 
supplying OPC values. 

Note If you use dcomcnfg.exe  to select a remote server, you can only run one versio
of that server, either locally or on one remote machine. You cannot use the sam
server on more than one machine.

How Do You Use DDE Servers with BridgeVIEW?

BridgeVIEW can communicate with any server using Microsoft Dynam
Data Exchange (DDE) as its interface. A DDE Server is treated as a sim
server in which you type in a device and item string to select a specific
point. For DDE Servers, you select DDE Server from the Server List in
the Tag Configuration Editor, and type in APPLICATION|TOPIC  for 
device in the I/O Group Configuration Dialog Box, and ITEM for item. See 
the How Do You Connect a Tag to a DDE Server? section in Chapter 3, Tag 
Configuration for more complete information on how to do this. If you ar
using Network DDE to use a DDE Server running on another machine,
the Network DDE name for the APPLICATION part of the name. Refer to 
BridgeVIEW Run-Time System Guide 7-8 © National Instruments Corporation
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your DDE Server documentation for the correct name for APPLICATION, 
the list of available TOPICS and ITEMS for each topic.

Note Unlike the servers written to the BridgeVIEW IA Device Server specification, 
off-the-shelf DDE Servers do not register themselves with BridgeVIEW. 
Therefore, BridgeVIEW cannot launch the DDE Server automatically when it 
runs your HMI application. To use a DDE Server, launch or run the DDE Serve
before you run your BridgeVIEW application. BridgeVIEW will post system erro
messages if it cannot connect to the DDE Server when it launches the 
BridgeVIEW Engine. Thereafter, it attempts to reconnect to the DDE Server 
periodically. 

How Do You View BridgeVIEW Server Configuration?

The Tag Configuration Editor shows the list of available servers, and a
registered devices and items for the server in the various Edit Tag scre
You also can use the Server Browser to view information about the de
servers registered with BridgeVIEW as well as the OPC Servers prese
your system and on the network. Launch the Server Browser by selec
Projects»Server Tools»Server Browser… or by pressing the Server 
Browser… button on the Engine Manager display. Use this utility to vie
the properties of the devices and items registered by each server. For
VI-based IA Device Servers, you can use this utility to display the serv
front panel while your application is running if you launch it from the 
Engine Manager. Typically, servers run with their front panel hidden. Y
can use the Server Browser to launch the server-specific configuration
utility from within BridgeVIEW, if one is available.

The Server Browser utility shows the server information stored in the ac
Common Configuration Database (.ccdb ) file. You can control which 
CCDB is active from the Server Explorer utility. 

Use the Server Browser to unregister a device server that you no long
want to use (BridgeVIEW device servers only). This keeps the server 
related information from appearing in the Edit Tag screens. Notice that 
invalidates any tags that use that server. Once you have unregistered 
© National Instruments Corporation 7-9 BridgeVIEW Run-Time System Guide
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server, you can no longer connect to it from BridgeVIEW, and you must 
its configuration utility again to register it with BridgeVIEW.

Figure 7-4.  Server Browser

The main screen of the Server Browser displays a list of servers availa
to BridgeVIEW in the Registered Servers list box if launched from the 
Engine Manager. The symbol to the left of the server name indicates 
whether it is loaded and running. A black diamond indicates that the se
is loaded and running. A white diamond indicates that the server is loa
but not running. No symbol indicates that the server is not being used in
current BridgeVIEW Tag Configuration. The Server Browser also displa
the path to the active CCDB in its title bar.

To view information registered for a specific server, double-click on the
server name in the Registered Servers list box, or press the View Server 
Devices… button. This invokes the View Server Device Information dialo
box shown in Figure 7-5.

To unregister a server that you no longer want to connect to your tags, p
the Unregister Server button with the server of interest selected in the 
Registered Servers list box. This invokes a dialog box asking you to 
confirm the operation.

Note Unregistering a server means that BridgeVIEW can no longer access that serv
and any tag configured to use that server no longer has a valid configuration. D
this only if no tags are configured to use that server and you no longer want to
access it from the Tag Configuration Editor. This does not apply to OPC or DD
Servers.
BridgeVIEW Run-Time System Guide 7-10 © National Instruments Corporation
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Registered Server Device and Item Parameters
Use the View Server Information dialog box to see a list of devices 
registered by a specific server, and for the selected device, view a tab
the registered items and item properties. The View Server Information
dialog box for BridgeVIEW device servers is shown below.

 

Figure 7-5.  View Server Information Dialog Box

You can sort this table by item name, data type, or direction, by select
which parameter you want to sort on in the Sort By: list.
© National Instruments Corporation 7-11 BridgeVIEW Run-Time System Guide
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Citadel and Open Database 
Connectivity

This appendix describes the Citadel database and the Open 
Database Connectivity (ODBC) driver, and includes a table that 
lists data transform commands. 

The Citadel historical database includes an Open Database Connecti
(ODBC) driver. This driver enables other applications to directly retriev
data from Citadel using Structured Query Language (SQL) queries. 
To use the SQL ODBC interface to Citadel, you must have installed 
the Citadel ODBC driver from the BridgeVIEW CD.

What is ODBC?

ODBC is a standard developed by Microsoft. It defines the mechanism
for accessing data resident in database management systems (DBMS
Virtually all Windows-based applications that can retrieve data from a 
database supporting ODBC.

Because Citadel allows simultaneous real-time access by multiple 
applications, the ODBC Driver can retrieve data from the Citadel datab
even while BridgeVIEW is running. There is no need to interrupt data 
collection in order to query the database. In fact, the ODBC Driver allo
multiple ODBC applications to perform SQL queries simultaneously.

Configuring the ODBC Driver

1. Shut down all applications that currently might be using ODBC. Su
applications include spreadsheets, word processors, database 
programs, MS Query, etc. You do not need to shut down BridgeVIE

2. Click the Start button, point to Settings, then click Control Panel. 
Otherwise, in the Main program group, choose the Control Panel ic

3. In the Control Panel dialog box, choose the 32-bit ODBC.
me System Guide
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4. In the Data Sources dialog box, choose Drivers….
 

5. Choose the Citadel driver and select Setup….
 

6. Make changes as appropriate. Select the historical logging directo
that was configured in your Tag Configuration (*.scf ) file for each 
data source. For example, if you want to query the historical data 
created by the Tanks System example, directory, modify the datab
path to C:\BridgeVIEW\Examples\User Applications\Tank 

System\Data . You also can modify the name of the data source to
reflect the application. An example of a modified ODBC Setup dial
box is shown below.
BridgeVIEW Run-Time System Guide A-2 © National Instruments Corporation
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Note Some applications are not completely ODBC compliant. If you plan to use 
Microsoft Query, Microsoft Access or Visual Basic, ensure Maximum Column 
Name Length does not exceed 62 characters. These packages cannot handle lon
tag names. Other packages that are truly ODBC compliant should be able to 
handle tag names up to 126 characters long. All threads whose tag names exc
the Maximum Column Name Length�are excluded from queries.

If you plan to use Microsoft Access or Visual Basic, select Convert special 
characters. This forces BridgeVIEW tag names into a format acceptable by the
applications by replacing characters within the tag names as follows:

7. Select OK  and CLOSE to exit.

What is SQL?

Structured Query Language (SQL) is an industry-standard language u
for retrieving, updating and managing data. You can use SQL to build 
queries that extract data from Citadel. Beyond simple data extraction, 
Citadel ODBC driver also includes many built-in data transforms that 
greatly simplify statistical analysis of retrieved data.

Original Character Converted To

period ( . ) backslash ( \ )

ampersand ( & ) at sign ( @ ) 

exclamation ( ! ) vertical bar ( | ) 
© National Instruments Corporation A-3 BridgeVIEW Run-Time System Guide
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How Do You Access Citadel Data?

The ODBC driver presents Citadel data to other applications as a Threads 
table. The table contains a field or column for each data member logge
the Citadel database.

Threads Table
The Threads table contains three fields you can use to specify query cri
and to time-stamp retrieved data: Interval , LocalTime , and UTCTime. 

Interval  allows you to specify the query value sample rate. Interval  can 
range from 10ms to several years. By default, Interval  is 1 (one day).

Remember, Citadel only logs a value when the value changes (it is 
event-driven). But using Interval , you can query Citadel for values evenly
spaced over a period of time. 

LocalTime and UTCTime indicate the time-stamps of when values are
logged. Citadel actually stores the time in UTCTime format and derives 
LocalTime from the stored time. When you do not specify a time, Citad
assumes midnight of the current day.

The following where clause from a query takes advantage of Interval �and 
LocalTime to select data over a specified time at one minute intervals.
Notice that time and date formats are the same as those used in 
BridgeVIEW.

SELECT * FROM Threads 

WHERE LocalTime > "12/1 10:00"

AND LocalTime < "12/2 13:00"

AND Interval = "1:00"

Data Transforms
Your queries can include special commands that perform data transfo
making it easy to manipulate and analyze historical data. The followin
table lists data transform commands.
BridgeVIEW Run-Time System Guide A-4 © National Instruments Corporation
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These data transforms allow you to directly calculate and retrieve comp
information from the database such as averages and standard deviatio
This time saving feature eliminates the need of extracting raw data first,
then massaging it in another application to come up with the needed 
information. 

Table A-1.  Data Transform Commands

Data Transform Command Description

Min{tag name} Returns the minimum for tag name 
across the interval.

Max{tag name} Returns the maximum for tag name 
across the interval.

Avg{tag name} Returns the average for tag name acros
the interval.

StDev{tag name} Returns the standard deviation for tag 
name across the interval.

Starts{tag name} Returns the number of starts (number of
transitions from OFF to ON) for tag 
name across the interval.

Stops{Datapoint} Returns the number of stops (number of
transitions from ON to OFF) for 
Datapoint across the interval.

ETM{Datapoint} Returns the amount of time Datapoint 
was in the ON state across the interval.

Qual{Datapoint} There might be gaps in the historical 
data threads in Citadel because of 
machine shutdown or BridgeVIEW 
shutdown. Qual returns the ratio of time 
for which valid data exists for a 
datapoint across the interval, to the 
length of the interval itself. Thus if 
valid data exists for only one-half of the 
interval, Qual would return 0.5.
© National Instruments Corporation A-5 BridgeVIEW Run-Time System Guide
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Assume, for example, that you want to find out how many times a 
compressor motor started in December. You also want to know its tota
runtime for the month. The following query provides the answers:

SELECT "Starts{MotorRun}",

"ETM{MotorRun}"

FROM Threads 

WHERE LocalTime >= "12/1/95" 

AND LocalTime < "1/1/96"

AND Interval = "31"

SQL Examples
The following examples are typical query statements; however, your 
queries may be much more involved, depending on your system 
requirements.

• Retrieves the most recent (current) value of every tag logged to 
Citadel.

SELECT *

FROM Threads 

• Retrieves the value of every tag logged today in one second 
increments. Note the interval value is specified within 

quotation marks.

SELECT *

FROM Threads 

WHERE Interval=“0:01”

• Retrieves and time-stamps the value of Powder  in one second 
increments from 8:50 this morning to now. Tag names are surroun
by quotes.

SELECT LocalTime, “Powder”

FROM Threads

WHERE LocalTime>“8:50”

AND Interval=“0:01”

• Retrieves and time-stamps the value of Liquid  input in one minute 
intervals for the month of October. Also indicates the input’s highe
occurring value within each minute.

SELECT LocalTime, “Liquid”, “Max{Liquid}”

FROM Threads

WHERE LocalTime>“10/1/96”

AND LocalTime<“11/1/96”

AND Interval=“1:00”
BridgeVIEW Run-Time System Guide A-6 © National Instruments Corporation
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• Retrieves an oven’s temperature set point and value at 3:00 p.m. a
shows the highest, lowest, and average temperatures between 2:0
p.m. and 3:00 p.m.
SELECT LocalTime, "OVEN1_SP", "OVEN1_PV", 

"Max{OVEN1_PV}", "Min{OVEN1_PV}", "Avg{OVEN1_PV}" 

FROM Threads

WHERE  LocalTime >= "14:00"

AND LocalTime < "15:00"

AND Interval = "1:00:00"

Queries Using Specific Applications
The following sections include information on queries using specific 
applications.

Using Microsoft Query with Citadel

Note The exact operation of Microsoft Query might change from version to version. 
Look in the online help for Microsoft Query for how to connect to an ODBC Data
Source for the exact instructions for your version of Microsoft Query.

Microsoft Query is a graphical data retrieval tool supplied with Microso
Office and Microsoft Excel. It allows you to build your SQL statement 
using interactive dialog boxes. Let’s step through a somewhat involved
example to show you a few simple tricks. 

To activate MS Query, double-click the MS Query icon, typically found in 
the MS Office program group. If you cannot find the icon, look in C:\

Program Files\Common Files\MicroSoft Shared\MSQuery\

Msqry32.exe . MS Query is not part of an MS Office standard installatio
so if you do not find it on your system, install it from your MS Office disk
© National Instruments Corporation A-7 BridgeVIEW Run-Time System Guide
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Choose File»New Query… to begin and select the data source you hav
setup for your Citadel historical directory as shown here. You might ne
to press Other… to access a list of data sources to select.�

 

Note If MS Query is unable to connect to a Citadel data source, you have not yet logg
data to Citadel; or the Database path�you specified in the ODBC Setup dialog box
is incorrect. 

Note If the Citadel data source is not listed in the Select Data Source dialog box, yo
might not have accessed it yet. Choose Other… and select Citadel from among the 
ODBC data sources. If Citadel is not listed as an ODBC Data Source, you need
install it. See the Configuring the ODBC Driver section for more information.

In the Add Tables dialog box, double-click Threads. Then close the 
dialog box. 

 

MS Query presents the full Query Window with the Threads table show
Notice the list of tag names in the Threads table. This list is a 
comprehensive list of all tags whose values have been logged to Citad
BridgeVIEW Run-Time System Guide A-8 © National Instruments Corporation
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To view the value of a field, double-click it or drag it to the data pane.
 

To view a data transform value, enter the function directly into a blank
column. For example, to view the minimum value of Liquid , you would 
enter "min{Liquid}" . Take special note of the use of quotation marks 
and braces. 

The above data set was retrieved using no specifying criteria, so the OD
driver used the default criteria. There are several ways to specify crite
For this example, we’ll use the criteria pane. Click the View Criteria  
button. 
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To add a field to the criteria pane, drag it from the list of fields to the 
Criteria Field.

 

When you enter qualifying criteria values, be sure to use the syntax 
demonstrated in the where clauses of the SQL Examples found in this
chapter. To specify a starting time of 9:45 today, for example, you wou
enter >= "9:45" .

As soon as you specify a criteria, Microsoft Query immediately retrieve
the specified data. You can save your query at any stage of its developm
As you build your query, the application builds an SQL statement. Wh
you click the SQL button, you can view and edit the query statement, a
shown in the following dialog box.
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Using Microsoft Excel with Citadel

Note The exact operation of Microsoft Excel might change from version to version. 
Look in the online help for Microsoft Excel for how to connect to an ODBC Data
Source for the exact instructions for your version of Microsoft Excel.

To extract data from Citadel, activate Excel and choose�Data»Get 
External Data…. This Excel command directly activates Microsoft Quer
From here you can use an existing query or create a new one. See the Using 
Microsoft Query with Citadel section earlier in this chapter. 

When you finish building your query, return the result set by choosing 
File»Return Data to Microsoft Excel…��Excel responds by presenting 
the Get External Data dialog box, enabling you to change or confirm th
destination cells of the result set. If you want to update the result set la
by requerying Citadel, be sure that Keep Query Definition remains 
selected. Choose OK  to write the data into the Excel worksheet. 

 

To update your result set, select any cell within the worksheet’s result 
choose�Data»Get External Data…, and click the Refresh button.
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Using Microsoft Access with Citadel
The exact operation of Microsoft Access might change from version to
version. Look in the online help for Microsoft Access for how to conne
to an ODBC Data Source for the exact instructions for your version of 
Microsoft Access.

Note The SQL/92 standard states that a delimited identifier is any string of not more
than 128 characters enclosed in quotation marks. It further states that characte
within a delimited identifier are exempt from SQL syntax checking. 
Unfortunately, Microsoft Access performs its own syntax checking for ODBC 
queries using a non-standard SQL syntax—even within delimited identifiers. Fo
this reason, National Instruments provides a Convert Special Characters 
selection in the Citadel ODBC Setup dialog box. When selected, the ODBC dri
converts the disallowed characters to something acceptable to Access, as follo
 

Therefore, Access recognizes a BridgeVIEW identifier such as Modbus1.40001
the delimited identifier Modbus1\40001.

When you query Citadel data using MS Access, You must use Micros
Access’s non-standard SQL syntax in your select statement. Be sure to
the special characters that are converted for Access compatibility and
double quotes around BridgeVIEW thread names. Finally, you must u
square brackets []  around identifiers, and #s around time stamps. For 
example, to retrieve LocalTime, Liquid, and Powder where LocalTime 
less than 10/22/95 18:00:00, and where Interval is one second, enter:

SELECT LocalTime, ["Liquid"], ["Powder"] 

FROM Threads 

WHERE LocalTime < #10/22/96 6:00:00 PM# 

AND Interval = '0:01'

Disallowed Character Converted To

period ( . ) backslash ( \ )

ampersand ( & ) at sign ( @ ) 

exclamation ( ! ) vertical bar ( | ) 
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To query Citadel from within MS Access, open a database, select File»Get 
External Data…�and then click Import . In the Import dialog box, in the 
Files of Type box, select ODBC Databases(). In the SQL Data Sources 
dialog box, choose your Citadel Data Source, as shown below.

 

In the Import Objects dialog box, choose Threads. The new table attaches
to your database. 

 

Now you can build queries in Access that extract data directly from the
Citadel database.

Using Visual Basic with Citadel
The exact operation of Visual Basic might change from version to versi
Look in the online help for Visual Basic for how to connect to an ODBC
Data Source for the exact instructions for your version of Visual Basic.

Note Visual Basic software relies on Microsoft Access DLLs for performing ODBC 
queries. Because it uses the non-standard SQL syntax of Access, be sure tha
© National Instruments Corporation A-13 BridgeVIEW Run-Time System Guide
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Convert Special Characters is selected in the Citadel ODBC Setup dialog box. 
See the note in the Using Microsoft Access with Citadel section in this appendix.

Using the Citadel ODBC Driver in Visual Basic is the same as using a
other ODBC driver. To retrieve and view data, create a Data control an
least one text control. 

First place a Data control on an open form. Set its Connect property to 
DSN=Citadel  (or the name of the Citadel data source) and double click
Record Source property to identify Threads as its source table.

You can leave the Record Source property set to Threads if you want to 
select all of the data for all of the threads in the Citadel database, or you
narrow your query by entering an SQL select statement in the Record 
Source property. For example, to retrieve LocalTime, Liquid, and Powd
where LocalTime is greater than 10/20/95 18:00:00 and less than 18:30
and where Interval is one minute, enter:

SELECT LocalTime, ["Liquid "], ["Powder "] 

FROM Threads 

WHERE LocalTime > #11/20/95 6:00:00 PM# 

AND LocalTime < #11/20/95 6:30:00 PM# 

AND Interval = '1:0'

You must use the SQL syntax of Microsoft Access in your select statem
Also remember to use the special characters that are converted for Ac
compatibility and double quotes around BridgeVIEW thread names to
identify them as delimited identifiers. Finally, Access SQL requires squar
brackets [ ] around identifiers, and #s around time stamps.

Now place a Text control on the form. Set its Data Source property to the 
name of your Data control—for example, Data1. Click the Data Field 
property to highlight it and then using the property sheet’s drop-down 
combo box, select the desired field name. All logged data members sh
be listed including LocalTime, Interval, Liquid, and so on. Repeat this s
for each data member you want to display on your form.
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Customer Communication

For your convenience, this appendix contains forms to help you gather the information necessa
to help us solve your technical problems and a form you can use to comment on the product 
documentation. When you contact us, we need the information on the Technical Support Form
the configuration form, if your manual contains one, about your system configuration to answer
questions as quickly as possible.

National Instruments has technical assistance through electronic, fax, and telephone systems to
provide the information you need. Our electronic services include a bulletin board service, an FT
a fax-on-demand system, and e-mail support. If you have a hardware or software problem, first 
electronic support systems. If the information available on these systems does not answer you
questions, we offer fax and telephone support through our technical support centers, which are
by applications engineers. 

Electronic Services

Bulletin Board Support

National Instruments has BBS and FTP sites dedicated for 24-hour support with a collection of
and documents to answer most common customer questions. From these sites, you can also d
the latest instrument drivers, updates, and example programs. For recorded instructions on how
the bulletin board and FTP services and for BBS automated information, call 512 795 6990. Yo
access these services at:

United States: 512 794 5422
Up to 14,400 baud, 8 data bits, 1 stop bit, no parity

United Kingdom:  01635 551422
Up to 9,600 baud, 8 data bits, 1 stop bit, no parity

France:  01 48 65 15 59
Up to 9,600 baud, 8 data bits, 1 stop bit, no parity

FTP Support

To access our FTP site, log on to our Internet host, ftp.natinst.com , as anonymous  and use 
your Internet address, such as joesmith@anywhere.com , as your password. The support files and
documents are located in the /support  directories.
me System Guide
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Fax-on-Demand Support

Fax-on-Demand is a 24-hour information retrieval system containing a library of documents on a
range of technical information. You can access Fax-on-Demand from a touch-tone telephone a
512 418 1111.

E-Mail Support (Currently USA Only)

You can submit technical support questions to the applications engineering team through e-mai
Internet address listed below. Remember to include your name, address, and phone number so
contact you with solutions and suggestions. 

support@natinst.com

Telephone and Fax Support
National Instruments has branch offices all over the world. Use the list below to find the technic
support number for your country. If there is no National Instruments office in your country, cont
the source from which you purchased your software to obtain support.

Country Telephone Fax

Australia 03 9879 5166 03 9879 6277
Austria 0662 45 79 90 0 0662 45 79 90 19
Belgium 02 757 00 20 02 757 03 11
Brazil 011 288 3336 011 288 8528
Canada (Ontario) 905 785 0085 905 785 0086
Canada (Québec) 514 694 8521 514 694 4399
Denmark 45 76 26 00 45 76 26 02
Finland 09 725 725 11 09 725 725 55
France 01 48 14 24 24 01 48 14 24 14
Germany 089 741 31 30 089 714 60 35
Hong Kong 2645 3186 2686 8505
Israel 03 6120092 03 6120095
Italy 02 413091 02 41309215
Japan 03 5472 2970 03 5472 2977
Korea 02 596 7456 02 596 7455
Mexico 5 520 2635 5 520 3282
Netherlands 0348 433466 0348 430673
Norway 32 84 84 00 32 84 86 00
Singapore 2265886 2265887
Spain 91 640 0085 91 640 0533
Sweden 08 730 49 70 08 730 43 70
Switzerland 056 200 51 51 056 200 51 55
Taiwan 02 377 1200 02 737 4644
United Kingdom 01635 523545 01635 523154
United States 512 795 8248 512 794 5678
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Technical Support Form
Photocopy this form and update it each time you make changes to your software or hardware, a
the completed copy of this form as a reference for your current configuration. Completing this f
accurately before contacting National Instruments for technical support helps our applications 
engineers answer your questions more efficiently.

If you are using any National Instruments hardware or software products related to this problem
include the configuration forms from their user manuals. Include additional pages if necessary.

Name ______________________________________________________________________

Company ___________________________________________________________________

Address ____________________________________________________________________

___________________________________________________________________________

Fax ( ___ ) ________________Phone ( ___ ) ______________________________________

Computer brand____________ Model ___________________Processor _____________________

Operating system (include version number) ________________________________________

Clock speed ______MHz   RAM _____MB Display adapter ________________________

Mouse ___yes   ___no     Other adapters installed___________________________________

Hard disk capacity _____MB Brand______________________________________________

Instruments used _____________________________________________________________

___________________________________________________________________________

National Instruments hardware product model _____________ Revision  ____________________

Configuration _______________________________________________________________

National Instruments software product ___________________ Version  _____________________

Configuration _______________________________________________________________

The problem is: ______________________________________________________________

___________________________________________________________________________

___________________________________________________________________________

___________________________________________________________________________

___________________________________________________________________________

List any error messages: _______________________________________________________

___________________________________________________________________________

___________________________________________________________________________

The following steps reproduce the problem: _______________________________________

___________________________________________________________________________

___________________________________________________________________________

___________________________________________________________________________

___________________________________________________________________________
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BridgeVIEW Hardware and Software Configuration Form
Record the settings and revisions of your hardware and software on the line to the right of each
Complete a new copy of this form each time you revise your software or hardware configuration
use this form as a reference for your current configuration. Completing this form accurately bef
contacting National Instruments for technical support helps our applications engineers answer 
questions more efficiently.

National Instruments Products

DAQ hardware ______________________________________________________________

Interrupt level of hardware _____________________________________________________

DMA channels of hardware ____________________________________________________

Base I/O address of hardware ___________________________________________________

Programming choice _________________________________________________________

BridgeVIEW version___________________________________________________________

Other boards in system ________________________________________________________

Base I/O address of other boards _______________________________________________

DMA channels of other boards _________________________________________________

Interrupt level of other boards __________________________________________________

Other Products

Application software developer __________________________________________________

Computer make and model ____________________________________________________

Microprocessor ______________________________________________________________

Clock frequency or speed ______________________________________________________

Type of video board installed ___________________________________________________

Operating system version ______________________________________________________

Operating system mode _______________________________________________________

Programming language _______________________________________________________

Programming language version _________________________________________________

Other boards in system ________________________________________________________

Base I/O address of other boards _______________________________________________

DMA channels of other boards _________________________________________________

Interrupt level of other boards __________________________________________________
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Documentation Comment Form
National Instruments encourages you to comment on the documentation supplied with our pro
This information helps us provide quality products to meet your needs.

Title: BridgeVIEW Run-Time System Guide

Edition Date: May 1998

Part Number: 321635C-01

Please comment on the completeness, clarity, and organization of the manual.

___________________________________________________________________________

___________________________________________________________________________

___________________________________________________________________________

___________________________________________________________________________

___________________________________________________________________________

___________________________________________________________________________

___________________________________________________________________________

If you find errors in the manual, please record the page numbers and describe the errors.

___________________________________________________________________________

___________________________________________________________________________

___________________________________________________________________________

___________________________________________________________________________

___________________________________________________________________________

___________________________________________________________________________

___________________________________________________________________________

Thank you for your help.

Name _____________________________________________________________________

Title ______________________________________________________________________

Company ___________________________________________________________________

Address ____________________________________________________________________

___________________________________________________________________________

E-Mail Address ______________________________________________________________

Phone ( ___ ) __________________________  Fax ( ___ ) ___________________________

Mail to: Technical Publications Fax to: Technical Publications
National Instruments Corporation National Instruments Corporation
6504 Bridge Point Parkway 512 794 5678
Austin, Texas 78730-5039
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Prefix Meanings Value

m- milli- 10–3

µ- micro- 10–6

n- nano- 10–9

A

access level Numeric value between 0 and 255 that can be used to control acces
your HMI.

ACK (Acknowledge) The sequence action that indicates recognition of a new alarm.

alarm An abnormal process condition. In BridgeVIEW, an alarm occurs if a t
value goes out of its defined alarm limits or if a tag has bad status. 

Alarm Summary A display of tags currently in alarm, or a display of tags previously in 
unacknowledged alarm state that have returned to a normal state.

analog tag A continuous value representation of a connection to a real-world I/O p
or memory variable. This type of tag can vary continuously over a rang
values within a signal range.

application software The application created using the BridgeVIEW Development System
executed in the BridgeVIEW Run-Time System environment.

B

bit array tag A multibit value representation of a connection to a real-world I/O poin
memory variable. In BridgeVIEW, this type of tag can be comprised of 
to 32 discrete values.

BridgeVIEW A program development application for real-time process monitoring a
control. BridgeVIEW uses the graphical development environment 
called G.
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BridgeVIEW Engine The heart of the BridgeVIEW system. It maintains the Real-Time Data
of all tag values and alarm states. The BV Engine runs as a separate pro
independent of your HMI application. 

BridgeVIEW Run-Time 
System

An execution environment for applications created using the BridgeVIE
Development System.

C

Citadel A database for storing historical tag values.

D

deadband In process instrumentation, the range through which an input signal 
vary, upon reversal of direction, without initiating an observable change
output signal. Deadband is usually expressed in percent of range.
See log deadband and update deadband.

device An instrument or controller that is addressable as a single entity and 
controls or monitors real-world I/O points. A device is often connected
the host computer through some type of communication network, or ca
a plug-in device.

device server An application that communicates with and manages a peripheral har
device such as a Programmable Logic Control (PLC), remote I/O devic
plug-in device. Device servers pass tag values to the BridgeVIEW Eng
in real time.

discrete tag A two-state (on/off) value representation of a connection to a real-worl
point. In BridgeVIEW, this type of tag can be either a one (TRUE) or a z
(FALSE).

dynamic attributes Tag attributes that do not require the BridgeVIEW Engine to be resta
when they are edited or reconfigured. Examples of dynamic attributes
include enabling logging operations, alarm attributes, and some scalin
attributes. See also static attributes.

E

Engine See BridgeVIEW Engine.
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engineering units (EU) Terms of data measurement, as degrees Celsius, pounds, grams an

error message An indication of a software or hardware malfunction, or an unaccept
data entry attempt.

event Something that happens to a tag in the BridgeVIEW system. Events inc
tags going into or out of alarm state and the user setting a tag value. 

G

G The graphical programming language used to develop BridgeVIEW 
applications.

group See tag group or I/O group.

H

Help window Special window that displays the description of controls and indicators.
window also accesses the Online Reference.

historical trend A plot of data (values versus time) showing values that were previous
acquired in the system or logged to disk.

Historical Trend Viewer 
(HTV)

A utility that accesses historical data from the Citadel historical databa

Human Machine 
Interface (HMI)

A graphical user interface for the user to interact with the BridgeVIEW
system.

I

I/O Group A set of related server items, all of which share the same server updat
and deadband.

input tag A tag that accepts Real-Time Database values from a device server.

Input/Output (I/O) tag A tag that accepts Real-Time Database values from a device server 
sends values to the server.

item A channel or variable in a real-world device that is monitored or control
by a BridgeVIEW device server.
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LabVIEW Laboratory Virtual Instrument Engineering Workbench. A program 
development application used commonly for test and measurement 
purposes.

log deadband The range through which a tag value must change before it is logged
Citadel.

log resolution The smallest change in a tag value stored in the historical database.

M

Man Machine 
Interface (MMI)

See Human Machine Interface (HMI).

MB Megabytes of memory.

memory tag A tag not connected to a real-world I/O point. Memory tags are used 
user-defined calculations. See also tag and network tag.

N

network tag A tag remotely connected to any type of tag on another BridgeVIEW 
Engine. See also tag and memory tag.

O

OPC OLE for Process Control. A COM-based standard defined by the OPC
foundation that specifies how to interact with device servers. COM is a
Microsoft 32-bit Windows technology.

operator The person who initiates and monitors the operation of a process.

output tag A tag that sends values to a device server whenever it is updated in t
Real-Time Database.
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Panel G Wizard A utility in BridgeVIEW that automates the process of creating front p
controls.

PID See Proportional Integral Derivative Control.

PLC See Programmable Logic Control.

polling A method of sequentially observing each I/O point or user interface con
to determine if it is ready to receive data or request computer action.

pop up To call up a special menu by clicking, usually on an object, with the ri
mouse button.

pop-up menus Menus accessed by popping up, usually on an object. Menu options p
to that object specifically.

positioning tool Tool used to move and resize objects. Resembles an arrow.

Programmable Logic 
Control (PLC)

A device with multiple inputs and outputs that contains a program you 
alter. BridgeVIEW Device Servers establish communication with PLCs

Proportional Integral 
Derivative (PID) Control

A combination of proportional, integral, and derivative control actions. 
Refers to a control method in which the controller output is proportiona
the error, its time history, and the rate at which it is changing. The erro
the difference between the observed and desired values of a variable t
under control action.

R

range The region between the limits within which a quantity is measured, 
received, or transmitted expressed by stating the lower and upper ran
values.

Real-Time Database 
(RTDB)

An in-memory snapshot of all tags in the system.

real-time trend A plot of data (values versus time) that is updated as each new point
acquired in the Real-Time Database.

reentrant execution Mode in which calls to multiple instances of a subVI can execute in pa
with distinct and separate data storage.
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representation Subtype of the numeric data type, of which there are signed and uns
byte, word, and long integers, as well as single-, double-, and 
extended-precision floating-point numbers, both real and complex.

resizing handles Angled handles on the corner of objects that indicate resizing points

RTDB See Real-Time Database.

S

sampling period The time interval between observations in a periodic sampling contro
system.

SCADA Supervisory Control and Data Acquisition.

sensor A device that produces a voltage or current output representative of s
physical property being measured, such as speed, temperature, or flo

string tag An ASCII character representation of a connection to a real-world 
I/O point.

supervisory control Control in which the control loops operate independently subject to 
intermittent corrective action.

system developer The creator of the application software to be executed in the BridgeV
Run-Time System.

System errors Errors that happen in the BridgeVIEW system, like a server going do
System errors are displayed in a dialog box, on the Engine User Interf
and also are logged in a syslog file.

System events Events that occur in the BridgeVIEW system, like an operator loggin
or a utility starting up. System events are logged in a syslog file.

T

tag A connection to a real-world I/O point or a memory variable. Tags can
one of four data types: analog, binary, discrete, or string.

tag attributes Parameters pertaining to a tag, like its alarm, limits, or Engineering U
Tag attributes are configured in the Tag Configuration Editor but can b
changed dynamically using the Tag Attributes VIs.
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Tag Browser A utility to view the configuration parameters of a tag, as configured in
Tag Configuration Editor.

Tag Configuration Editor A utility to configure various parameters of a tag, such as connection
information, scaling, or logging.

tag group A set of tags primarily used for reporting and acknowledging alarms. A
can be associated with only one tag group. All tags belong to the grou
<ALL> by default.

Tag Monitor A utility to view the current value of a tag, along with its status and ala
state.

tag status A variable that determines the validity of a tag value. A negative statu
represents an error, a positive status represents a warning, and a stat
zero represents a good tag value.

timestamp The exact time and date at which a tag value was sampled. Tag valu
stored with their timestamps in the RTDB.

trend A view of data over time. Trends can display real-time or historical da

U

update deadband The range through which a tag value must change before it is update
Real-Time Database.

user See operator.

user-defined constant Block diagram object that emits a value you set.

V

virtual instrument A program in the graphical programming language G; so called beca
models the appearance and function of a physical instrument.
© National Instruments Corporation G-7 BridgeVIEW Run-Time System Guide
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A
access levels and privileges, 6-1

See also security.
defaults (table), 6-1
finding access levels, 6-3
finding environment access privileges, 6-3
modifying

list of available user access levels, 6-6
Access Levels dialog box, 6-3
adding network tags, 3-7
alarm attributes, 3-3
alarm limit, 4-1
alarm priority, 4-2
alarm states, 4-1
alarms

configuring logging and printing, 4-2
defining group of tags for alarming, 3-21
Event Configuration dialog box

event logging and printing selections 
(table), 4-3

illustration, 4-2
log and print format selections, 4-4

logging, 4-5
printing, 4-5
purpose and use, 1-4, 4-1
tag configuration, 3-30

alarm deadband on analog tags, 3-36
analog tags, 3-34
Auto Ack on Normal option, 3-38
configuration attributes (table), 3-31
discrete tags, 3-35
enabling alarms, 3-33
keeping alarms unacknowledged, 3-38
string tags, 3-36
types of alarms, 3-30
User Must Ack option, 3-38

viewing, 4-6

Alarms Configuration Attributes (table), 3-31
analog tags

alarm configuration, 3-34
alarm deadband, 3-36
creating, 3-5
purpose and use, 3-10
scaling, 3-26

analog tag scaling dialog box, 3-26
assigning units, 3-27
linear scaling, 3-27
square root scaling, 3-27

attributes
alarm, 3-3
connection, 3-2
general, 3-2
operation, 3-2
scaling, 3-2
static vs. dynamic, 3-3
tag, 3-1

B
bit array tags

alarm configuration, 3-36
creating, 3-5
purpose and use, 3-10
scaling, 3-29

Bit Array Tag Configuration dialog 
box, 3-29

scaling examples (table), 3-30
BridgeVIEW

architecture, 1-6
getting started, 1-8
installation, 1-1
overview, 1-2
purpose and use, 1-2
required system configuration, 1-1
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BridgeVIEW client, 3-6
BridgeVIEW Configuration file, 3-4

edting, 3-4
BridgeVIEW Engine

description, 1-6
increasing throughput using 

deadband, 3-23
overview, 1-3
parameter configuration, 3-38

memory allocation parameters 
(table), 3-39

BridgeVIEW environment, 2-1
Engine Manager, 2-3
online help, 2-14
Project menu items (table), 2-1
system errors and events, 2-6
Tag Browser utility, 2-7
Tag Monitor, 2-9

BridgeVIEW server, 3-6
BridgeVIEW System Log file, 2-5
Browse OPC Servers on Network dialog box, 

illustration, 7-7

C
Citadel Historical Database

data transform commands (table), A-5
ODBC driver, A-1
overview, 5-1

Citadel threaded database
retrieving data, A-6

client
BridgeVIEW, 3-6

connection
tag attributes, 1-4

connection attributes, 3-2
customer communication, xv

D
data logging

See historical data logging and extraction
DDE server

connecting tag to, 3-20
using with BridgeVIEW, 7-8

deadband
alarm deadband on analog tags, 3-36
increasing engine throughput, 3-23
logging (table), 3-22
purpose and use, 3-23
setting update too high (note), 3-23
updating (table), 3-22

deleting tags, 3-5
device servers. See servers.
discrete tags

alarm configuration, 3-35
creating, 3-5
purpose and use, 3-10

documentation
conventions used in manual, xiv
organization of manual, xiii
related documentation, xv

dynamic attributes, 3-3
Dynamic Data Exchange server

See DDE server.
dynamic vs. static attributes, 3-3

E
Edit User Accounts dialog box, 6-5
editing tags, 3-5
Engine

communication with device servers 
(note), 3-5

Engine Manager
See also BridgeVIEW Engine.
Enable error, 2-4
Engine Status, 2-4
illustration, 2-3
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Log Events, 2-4
Log Historical Data, 2-4
Print Events, 2-4
Quit Engine, 2-4
Run/Stop Engine, 2-4
Server Browser, 2-4
Show/Hide System Event Display, 2-4

engineering units
assigning to an analog tag, 3-27
conversion by BridgeVIEW Engine, 1-6

environment security. See security.
Event Configuration dialog box

event logging and printing selections 
(table), 4-3

illustration, 4-2
log and print format selections (table), 4-4

events
configuring logging and printing, 4-2
Event Configuration dialog box

event logging and printing selections 
(table), 4-3

illustration, 4-2
log and print format selections 

(table), 4-4
logging

procedure, 4-5
setting file paths, 3-38
shift configuration, 3-39
turning on at startup, 3-38

printing, 4-5
purpose and use, 1-3, 1-5
types of events, 1-5
viewing, 4-6

exporting a list of users to a file, 6-6
exporting users to another computer on the 

network, 6-7
extracting historical data

See historical data logging and extraction.

F
file

.scf , 3-4
BridgeVIEW Configuration, 3-4
SCADA Configuration, 3-4

G
general attributes, 3-2
General Attributes dialog box, 3-11

H
historical data logging and extraction

See also Historical Trend Viewer (HTV).
Citadel Historical Database, 5-1, A-1
configuring tags to log data or 

events, 3-24
logging, 5-2

configuring, 5-2
steps, 5-2
techniques for turning on and off, 5-2

overview, 1-5
setting file paths, 3-38
trends, 5-1
turning on at startup, 3-38

Historical Logging Configuration dialog box
illustration, 5-3
parameters (table), 5-3

Historical Trend Viewer (HTV), 5-4
exporting data to spreadsheet, 5-8
illustration, 5-4
launching, 2-1
live mode, 5-9
online help, 5-8
plot colors and style in trend

changing, 5-8
Select Tags dialog box, 5-5
selecting tags to display, 5-5
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n 
tag, time, and color preferences
setting, 5-9

time axis, changing, 5-5
manual changes, 5-6
panning button functions, 5-6

timespan of displayed data
changing, 5-7

viewing newly logged data, 5-9
viewing tag value at specific point in 

time, 5-7
Y axis, changing, 5-7
zooming in on a trend, 5-8

HTV. See Historical Trend Viewer (HTV).
Human Machine Interface

overview, 1-1

I
I/O connection attributes, 3-2
I/O Group configuration, 3-14

attributes (table), 3-16
dialog box, 3-15
options, 3-15
server configuration options, 3-16

importing a list from users to a file, 6-7
importing users from another computer on the 

network, 6-9
industrial automation device servers. See 

servers.
installing BridgeVIEW, 1-1
Interval query field, A-4
item, 7-1

configuration options, 3-18

L
Live Mode (HTV), 5-9
LocalTime query field, A-4
logging

alarms and events, 4-5
configuration, 4-2

historical data
See historical data logging and 

extraction.
logging in and out, 6-3

M
manual. See documentation.
memory

configurable memory allocation 
parameters (table), 3-39

memory tags, 3-19
Microsoft Access

retrieving Citadel data, A-12
Microsoft Excel

retrieving Citadel data, A-11
Microsoft Query

retrieving Citadel data, A-7

N
network tags, 3-6

adding, 3-7
networking BridgeVIEW

exporting users to another computer on 
the network, 6-7

importing users from another computer o
the network, 6-9

using remote OPC servers, 7-6
NI-DAQ 6.x, 7-3
NI-DAQ OPC server

installing, 7-3

O
ODBC driver, A-1

threads table, A-4
using, A-6

online help
accessing, 2-14
Historical Trend Viewer (HTV), 5-8
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OPC servers
connecting to tags, 3-20
remote, 7-6
using with BridgeVIEW, 7-4

Open Database Connectivity (ODBC) 
driver, A-1

operation attributes, 3-2
operations

types of operations, 1-4

P
password, changing, 6-4
printing alarms and events, 4-5

configuration, 4-2
privileges

See access levels and privileges.
Privileges dialog box, 6-4
Project menu, 2-1

Historical Trend Viewer, 2-1
Launch Engine, 2-1
Security»Access Levels, 2-2
Security»Change Password, 2-2
Security»Edit User Accounts, 2-2
Security»Login, 2-2
Security»Logout, 2-2
Security»Privileges, 2-2
Server Tools»Server Browser, 2-2
Tag»Browser, 2-2
Tag»Configuration, 2-3
Tag»Monitor, 2-3

project menu, 2-1

R
Real-Time Database, 1-4, 1-7

See also BridgeVIEW Engine; tag 
configuration; operations

registered server device and item 
parameters, 7-11

RTDB. See Real-Time Database.

S
SCADA Configuration file, 3-4

contents, 3-4
editing, 3-4
running one .scf file at a time (note), 3-4

scaling, 3-24
purpose and use, 1-4

scaling attributes, 3-2
.scf  file, 3-4
security

environment security
Access Levels dialog box, 6-3
changing password, 6-4
creating and modifying user 

accounts, 6-4
Edit User Accounts dialog box, 6-5
exporting a list of users to a file, 6-6
finding access level, 6-3
finding environment access 

privileges, 6-3
logging in and out, 6-3
modifying list of available user 

access levels, 6-6
Privileges dialog box, 6-4
restricting access, 6-4

environment security importing a list of 
users from a file, 6-7

overview, 1-5
Project menu items

Security»Access Levels, 2-2
Security»Change Password, 2-2
Security»Edit User Accounts, 2-2
Security»Login, 2-2
Security»Logout, 2-2
Security»Privileges, 2-2

Select Tags to Monitor dialog box, 2-12
Server Brower utility, 2-5
Server Browser

Browse OPC Servers on Network dialog
box, illustration, 7-7
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launching, 2-1
main screen (illustration), 7-10
Show Server User Interface button, 2-6
unregistered servers, 7-10
using remote OPC servers, 7-6
View Server Information dialog box, 

illustration, 7-6
viewing BridgeVIEW server 

configuration, 7-9
viewing OPC server Items, 7-5

Server Browser button, 7-9
server configuration

options, 3-16
server/client interaction

illustration, 3-6
servers

See also Server Browser.
BridgeVIEW, 3-6
communication with Engine (note), 3-5
DDE servers and BridgeVIEW, 7-9
installation and configuration, 7-2

launching server configuration 
utilities from Tag Configuration 
Editor, 3-40

NI-DAQ OPC server, 7-3
using BridgeVIEW Device Servers 

CD, 7-4
items, 7-1
overview, 1-7
purpose and use, 7-1
Server Browser, 7-5
using OPC servers with BridgeVIEW, 7-4
using remote OPC servers, 7-6
viewing server configuration

registered server device and item 
parameters, 7-11

View Server Device Information 
dialog box, 7-6

setting file paths, 3-38
shift configuration, 3-39

spreadsheets
exporting configuration fields, 3-8
important points, 3-9
importing data (note), 3-9
saving trend data

Historical Trend Viewer (HTV), 5-8
storing tag configuration data, 3-8

SQL. See Structured Query Language.
static attributes, 3-3
static vs. dynamic attributes, 3-3
Status Details dialog box, 2-11
string tags

alarm configuration, 3-36
creating, 3-5
purpose and use, 3-11

Structured Query Language (SQL)
examples, A-6

System Event Display
illustration, 2-5
items displayed, 2-5
showing/hiding, 2-4
using, 2-5

T
tag

attributes, 3-11
connection to DDE server, 3-20
connection to OPC server, 3-20

tag attributes, 3-1, 3-11
alarm, 3-3
connection, 3-2
general, 3-2
operation, 3-2
scaling, 3-2
static vs. dynamic, 3-3

Tag Browser utility, 2-7
fields

Access rights, 2-8
Alarms enabled, 2-8
Auto Ack, 2-8
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Browse, 2-8
Configuration File, 2-8
Configured Tags, 2-8
Description, 2-8
Engine Status, 2-8
Full Scale, 2-9
Group, 2-8
Item, 2-8
Name, 2-8
Server, 2-8
Type, 2-8
Units, 2-9
Zero Scale, 2-9

illustration, 2-7
launching, 2-1
purpose and use, 2-9

tag configuration, 3-10
See also Tag Configuration Editor
alarms, 3-30, 3-33

alarm deadband on analog tags, 3-36
analog tags, 3-34
bit array tags, 3-36
discrete tags, 3-35
enabling alarms, 3-33
keeping alarm 

unacknowledged, 3-38
string tags, 3-36
types of alarms, 3-30

alarms configuration attributes (table)
Alarm Deadband, 3-31
Alarm Invert Mask, 3-32
Alarm Message, 3-33
Alarm On, 3-32
Alarm Select Mask, 3-33
Alarms Enabled, 3-31
Auto Ack, 3-31
Bad Status Enabled, 3-31
Bad Status Priority, 3-31
Discrete Enabled, 3-32
Discrete Priority, 3-32
HI Enabled, 3-31

HI Limit, 3-31
HI Priority, 3-31
HI_HI Enabled, 3-31
HI_HI Limit, 3-31
HI_HI Priority, 3-31
LO Enabled, 3-31
LO Limit, 3-32
LO Priority, 3-32
LO_LO Enabled, 3-32
LO_LO Limit, 3-32
LO_LO Priority, 3-32
Tag Last Modified, 3-33

connecting to OPC server, 3-20
connection

connecting tag to DDE server, 3-20
defining group of tags for 

alarming, 3-21
generate tags from server 

information, 3-19
I/O Group configuration

server configuration 
options, 3-16

item configuration
options, 3-18

memory tags, 3-19
data types, 3-10
general configuration attributes 

(table), 3-12
Maximum Length, 3-12
Tag Description, 3-12
Tag Group, 3-12
Tag Name, 3-12

I/O Group Configuration Attributes 
(table), 3-16

Communication Resource, 3-16
Device Comm Resource, 3-16
I.O Group Update Deadband, 3-16
I/O Group Description, 3-16
I/O Group Device, 3-16
I/O Group Name, 3-16
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I/O Group Update Rate (secs), 3-16
Server Name, 3-16

operations, 3-21
increasing engine throughput using 

deadband, 3-23
logging data or events, 3-24
setting deadband, 3-23
Tag Operations dialog box, 3-21

operations configuration attributes 
(table), 3-22

Initial Value, 3-23
Log Data, 3-22
Log Data Deadband, 3-22
Log Resolution, 3-22
Log/Print Events, 3-23
Set Initial Value, 3-23
Update Deadband, 3-22

scaling
analog tags, 3-26
bit array tags, 3-29
discrete tags, 3-24
string tags (note), 3-25

scaling configuration attributes 
(table), 3-24

Coerce, 3-25
Eng Full Scale, 3-24
Eng Zero Scale, 3-25
Raw Full Scale, 3-24
Raw Zero Scale, 3-24
Scaling, 3-25
Scaling Invert Mask, 3-25
Scaling Select Mask, 3-25
Units, 3-25

setting initial tag value at startup, 3-24
Tag Configuration Editor, 3-3

See also tag configuration.
adding network tags, 3-7
creating tags, 3-5
deleting tags, 3-5
editing tags, 3-5

Engine parameter configuration, 3-39
configurable memory allocation 

parameters (table), 3-39
overriding default settings, 3-39
setting file paths for historical and 

event files, 3-38
shift configuration, 3-39
turning on historical and event 

logging at startup, 3-38
illustration, 3-4
launching, 2-3, 3-3
launching server configuration 

utilities, 3-40
Set Tag Parameter Defaults dialog 

box, 3-8
setting default values for configuration 

fields, 3-7
spreadsheets for storing configuration 

data, 3-8
tag data types, 3-10

analog, 3-10
bit array, 3-10
discrete, 3-10
overview, 1-3
string, 3-11

Tag Monitor utility, 2-9
fields

Monitor Timeout (secs), 2-11
Select Tags to Monitor, 2-11
Status Details, 2-11
Tag Display Table, 2-11
Trigger Tag, 2-11

illustration, 2-10
launching, 2-3, 2-9
overview, 2-9
Preferences dialog box, 2-13
Select Tags to Monitor dialog box, 2-12
Status Details dialog box, 2-11

tag operations
types of operations, 1-4
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tag scaling
purpose and use, 1-4

tags
creating, 3-5
data types. See tag data types.
deleting, 3-5
editing, 3-5
network, 3-6
purpose and use, 1-3, 3-1
types, 1-3

Threads table, A-4
trends

See also Historical Trend Viewer (HTV).
historical trends, 5-1
purpose and use, 1-5, 5-1
real-time trends, 5-1

U
user accounts

exporting to another computer, 6-7
importing from another computer, 6-9

user acounts
exporting a list of users to a file, 6-6
importing a list of users from a file, 6-7

UTCTime query field, A-4

V
View Server Device Information dialog 

box, 7-11
viewing new data automatically after 

logging, 5-9
Visual Basic

retrieving Citadel data, A-14
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